DTMF echo killing my project! Help!

I’ve been working on my first Asterisk application to replace an aging system using some old Dialogic cards. I’m about 90% through the system and basically just need to debug it now. But unfortunately it may all have been in vain unless I can solve this problem…

Users are given a prompt, at which I am trying to Read() in a 6-digit confirmation number. The problem is, I’m getting an echo on DTMF characters. Instead of 123456 I get 112345 or 123344, etc.

I’m using Vitelity as the SIP provider for the Asterisk server and am testing it on a Cisco IP phone here at my office. I’ve also tried testing it using my cell phone but I still get the same DTMF echo, so I don’t believe it’s the receiving phone that’s the problem. I’ve scoured the net for various fixes but nothing seems to be working. I’ve changed the dtmfmode to no avail, tried relaxdtmf. Dunno.

Has anyone else had a problem like this? Anybody have ANY suggestions on what to do/check out? I’m at a complete loss for how to solve this and my boss is breathing down my neck to get this up and running. But this echo makes the system almost completely unusable. If I’m frustrated trying to work it and I created it, I can only imagine what our customers would think of it! Please help!


Your SIP service provider should be decoding the tones.

What DTMF handling mode do you have configured?

I currently have dtmfmode set to ‘auto’. I had tried the other two settings, with inband not sending tones at all, and rfc2833 not providing anything better…

Did you mean “info”?

All except “inband” result in the service provider doing the DTMF decoding. “inband” will not work reliably with anyting other than A-law or mu-law codecs.

It looks to me as though the problem is in the service provider’s system.

Thanks. I’m going to write to their support staff and see if I can get a ticket on this. I’ll report back with my results :smile: