DTLS failed on Chorme, FireFox 's lastest version

Hello every body!
I build Web phone by Asterisk 13.12.0, Jssip libary and WebRTC.
and when I update browser version to lastest version. the call is Terminate after 2s pick up the call
on Asterisk CLI messages:

ERROR[28144][C-00000000] res_rtp_asterisk.c: DTLS failure occurred on RTP instance ‘0x7f98d0005de8’ due to reason ‘tlsv1 alert protocol version’, terminating

I search the Issue on google and I know reason is the browser 's lastest version not support DTLS 1.0. so I updated openssl version by path and packages. when I check by openssl version command and by yum list installed | grep openssl:

yum list installed | grep openssl
openssl.x86_64 1:1.0.2k-21.el7_9 @updates
openssl-libs.x86_64 1:1.0.2k-21.el7_9 @updates

openssl version
OpenSSL 1.1.1j 16 Feb 2021

I restarted Asterisk and tested again and result are still same, it not working and I still can’t call
Can someone tell me why and what am I doing wrong
Thanks for my bad English

You need to recompile Asterisk now that you have the new version of OpenSSL for it to be utilized.

I have never tried that, can you give me some advice

I’m just referring to the build and install procedure. You can find the reference here:


1 Like

Thank you so much for your reply

1 Like

Also note that reliable implementation of WebRTC requires that you use current versions of Asterisk and continually update them. This is because WebRTC keeps changing.

Asterisk 13 no longer receives changes that are not security related, and 13.12 is a very old sub-version of Asterisk 13.

I think you should always expect to have to compile it yourself when using WebRTC.

My problem was solved after I rebuilt the asterisk, thank you very much!!!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.