Disable Jitter Buffer


#1

How do I completely disable the jitterbuffer?

sip.conf:

jblog=no
jbenable=no
jbforce=no

iax.conf:

jitterbuffer=no

I even put this in my dialplan:

exten => 1,n,Set(JITTERBUFFER(disabled)=)

Yet in the logs:

[Aug 6 12:08:39] WARNING[32605][C-00000001]: chan_iax2.c:1228 jb_warning_output: Resyncing the jb. last_delay 0, this delay -440715316, threshold 1000, new offset 440715316


#2

First of all, which signalling protocol are you using: SIP or IAX? Implamantation of jitter buffer differs in these channel drivers.
Second, what kind of issue(-s) are you experiencing so that you are blaming jitter buffer for their appearance?

Anyway… to disable jitter buffer in IAX:

jitterbuffer=no
resyncthreshold=-1


#3

Im using SIP and for the life of me never understood why iax is in the logs if Im using SIP. Im blaming jitter because log entries and being generated that at least somewhat clearly relate.

In my OP I show how JB is disabled in both instances.


#4

Something else. This seems to happen when using Local channels:

[Aug 6 14:44:07] WARNING[9118][C-00000001]: chan_iax2.c:1228 jb_warning_output: Resyncing the jb. last_delay 0, this delay -75337982, threshold 1000, new offset 75337982
[Aug 6 14:44:12] NOTICE[9213]: pbx_spool.c:463 attempt_thread: Call completed to Local/s@playconf

Maybe the local channel is using IAX? Should I change that somehow?


#5

This makes the messages go away:

modules.conf
noload => chan_iax2.so

But no idea if thats a good thing to do or not.


#6

If you are not using IAX at all, you can safely disable this channel driver.


#7

I wonder if you have security problems and these are attacking calls that generating the log messages.


#8

Seems unlikely, I have the box locked down pretty tight. Playing around with the modules I managed to safely disable ~200 of them.

Last question: any way to make these notices go away?

[Aug 6 14:44:12] NOTICE[9213]: pbx_spool.c:463 attempt_thread: Call completed to Local/s@playconf

This happens after the system processes a .call file in /var/spool/asterisk/outgoing. not sure why that would have to be seen.