Delay when answering


We have an Asterisk system which is working great. The only problem is that when somebody dials in from the outside there is about a 2 second delay before the inbound caller can hear the person who picked up the phone. So the internal extension will ring, the person picks up the phone and can hear the caller, but the inbound caller cannot hear them.

We don’t have this problem on internal calls. The automated attendant initially picks up the calls, so it wouldn’t seem to be an issue with the VOIP service provider making the connection, as it is already established by the time the call is forwarded through to the extension. So the call flow is:

outside caller -----> our automated attendant (asterisk box) --------> internal extension (delay only occurs after the auto attendant xfers the call to the internal extension)

We are using Polycom Soundpoint IP 330 phones.

Any help is greatly appreciated.

Is any of your gear behind NAT?

Do you have “canreinvite=yes” turned on? If so, try setting it to “off”

We have a monowall firewall with a 1:1 NAT for the asterisk server with all ports open to our VOIP provider. There is nothing between the Asterisk server and any of the phones.

I’m not sure about that other setting. I’m very well versed in Windows but this is my first foray into *nix.

canreinvite would be a setting in sip.conf
my bad :smile:

Here is the sip.conf I don’t see it listed

; Note: If your SIP devices are behind a NAT and your Asterisk
; server isn’t, try adding “nat=1” to each peer definition to
; solve translation problems.

#include sip_general_additional.conf

bindport = 5060 ; Port to bind to (SIP is 5060)
bindaddr = ; Address to bind to (all addresses on machine)
; If you need to answer unauthenticated calls, you should change this
; next line to ‘from-trunk’, rather than ‘from-sip-external’.
; You’ll know this is happening if when you call in you get a message
; saying "The number you have dialed is not in service. Please check the
; number and try again."
context = from-sip-external ; Send unknown SIP callers to this context
callerid = Unknown

; Reported as required for Asterisk 1.4

; enable and force the sip jitterbuffer. If these settings are desired
; they should be set in the sip_general_custom.conf file as this file
; will get overwritten during reloads and upgrades.
; jbenable=yes
; jbforce=yes

; #, in this configuration file, is NOT A COMMENT. This is exactly
; how it should be.
#include sip_general_custom.conf
#include sip_nat.conf
#include sip_registrations_custom.conf
#include sip_registrations.conf
#include sip_custom.conf
#include sip_additional.conf
#include sip_custom_post.conf

The configuration for your provider will be in one of the configs included at the bottom.
Check them too.