Dahdi-linux-complete-2.11.1+2.11.1 won't compile under fedora 4.11.3-200.fc25.x86_64


#1

Hi everyone,

I can’t compile dahdi anymore under the newly upgraded fedora.

fedora 4.11.3-200.fc25.x86_64
asterisk-14.5.0
dahdi-linux-complete-2.11.1+2.11.1

I have:

/usr/src/phones/dahdi-linux-complete-2.11.1+2.11.1/linux/drivers/dahdi/dahdi-base.c: In function ‘dahdi_ioctl_iomux’
/usr/src/phones/dahdi-linux-complete-2.11.1+2.11.1/linux/drivers/dahdi/dahdi-base.c:5954:7: error: implicit declaration of function ‘signal_pending’[-Werror=implicit-function-declaration]
if (signal_pending(current)) {
^~~~~~~~~~~~~~
cc1: some warnings being treated as errors
scripts/Makefile.build:294: recipe for target ‘/usr/src/phones/dahdi-linux-compl
ete-2.11.1+2.11.1/linux/drivers/dahdi/dahdi-base.o’ failed
make[3]: *** [/usr/src/phones/dahdi-linux-complete-2.11.1+2.11.1/linux/drivers/d
ahdi/dahdi-base.o] Error 1
Makefile:1496: recipe for target ‘module/usr/src/phones/dahdi-linux-complete-2
.11.1+2.11.1/linux/drivers/dahdi’ failed
make[2]: *** [module/usr/src/phones/dahdi-linux-complete-2.11.1+2.11.1/linux/d
rivers/dahdi] Error 2
make[2]: Leaving directory '/usr/src/kernels/4.11.3-200.fc25.x86_64’
Makefile:74: recipe for target ‘modules’ failed

Do you have an idea what goes wrong?
Thanks for your help.

Bye,
Jean-Louis


#2

This was mentioned on the mailing list[1] and an issue[2] created with the fixes.

[1] http://lists.digium.com/pipermail/asterisk-dev/2017-June/076354.html
[2] https://issues.asterisk.org/jira/browse/DAHLIN-354


#3

Thank you so much.
It’s working now.

but still:

/usr/share/dahdi/waitfor_xpds: line 106: astribank_is_starting: command not found
D: auto '/sys/bus/dahdi_devices/devices/pci:0000:02:08.0’auto-assign /sys/bus/dahdi_devices/devices/pci:0000:02:08.0
Running dahdi_cfg:

Bye,
Jean-Louis


#4

You should contact Xorcom for problems with Astribank.


#5

But, I don’t have any Astribank installed.
I have only one card 5AEX410 with 1 FXO, 1 FXS and 1 5VPMADT032.

Loading DAHDI hardware modules: wctdm24xxp:

/usr/share/dahdi/waitfor_xpds: line 106: astribank_is_starting: command not found


#6

I am getting the same error!
Could you please let me know how to apply the patches?
I am a beginner on this and need more advice on how to use the pathces.

Thanks in advance!

Mardo


#7

No-one mentioned patches. The warnings are harmless, but you might not need dahdi.


#8

jcolp above put two links, the second one shows some patches that have fixed the issue for some people.
I want to apply them, but need some help on how to do that!

Thx.


#9

Do you know by chance the steps to apply the patches on the [2] link?

Thanks in advance!


#10

Install the source tree for the version to which the patches relate. Install the development tools. Use the patch utility (see man patch). Build and install Asterisk following the instructions in the top directory of the source tree.


#11

Maybe I am missing something, but why hasn’t this patch been incorporated into the regular DAHDI version? It’s still the same version as of Nov 2018 and the identical problem arises.

Thanks