Error in dahdi with asterisk 15.5 on Ubuntu 18.04 LTS

Hi, Everyone , today i have install the asterisk 15.5 asterisk on ubuntu 18.04 LTS but i am facing below mention error with all version of dahdi, so please guide me how can i fix this error …i have tried a lot of time but this error is still there.


^~~~~~
/usr/src/dahdi-linux-complete-2.11.1+2.11.1/linux/drivers/dahdi/dahdi-base.c: In function âdahdi_ioctl_iomuxâ:
/usr/src/dahdi-linux-complete-2.11.1+2.11.1/linux/drivers/dahdi/dahdi-base.c:5954:7: error: implicit declaration of function âsignal_pendingâ; did you mean âtimer_pendingâ? [-Werror=implicit-function-declaration]
if (signal_pending(current)) {
^~~~~~~~~~~~~~
timer_pending
/usr/src/dahdi-linux-complete-2.11.1+2.11.1/linux/drivers/dahdi/dahdi-base.c: In function âcoretimer_initâ:
/usr/src/dahdi-linux-complete-2.11.1+2.11.1/linux/drivers/dahdi/dahdi-base.c:10142:2: error: implicit declaration of function âinit_timerâ; did you mean âinit_timersâ? [-Werror=implicit-function-declaration]
init_timer(&core_timer.timer);
^~~~~~~~~~
init_timers
/usr/src/dahdi-linux-complete-2.11.1+2.11.1/linux/drivers/dahdi/dahdi-base.c:10143:28: error: assignment from incompatible pointer type [-Werror=incompatible-pointer-types]
core_timer.timer.function = coretimer_func;
^
cc1: some warnings being treated as errors
scripts/Makefile.build:332: recipe for target ‘/usr/src/dahdi-linux-complete-2.11.1+2.11.1/linux/drivers/dahdi/dahdi-base.o’ failed
make[3]: *** [/usr/src/dahdi-linux-complete-2.11.1+2.11.1/linux/drivers/dahdi/dahdi-base.o] Error 1
Makefile:1552: recipe for target ‘module/usr/src/dahdi-linux-complete-2.11.1+2.11.1/linux/drivers/dahdi’ failed
make[2]: *** [module/usr/src/dahdi-linux-complete-2.11.1+2.11.1/linux/drivers/dahdi] Error 2
make[2]: Leaving directory ‘/usr/src/linux-headers-4.15.0-29-generic’
Makefile:77: recipe for target ‘modules’ failed
make[1]: *** [modules] Error 2
make[1]: Leaving directory ‘/usr/src/dahdi-linux-complete-2.11.1+2.11.1/linux’
Makefile:28: recipe for target ‘all’ failed
make: *** [all] Error 2

thanks in advance

Is this being installed on a VM? Did you run apt-get update and apt-get upgrade?

Have you tried to “make clean” before trying to compile?

sir i am not using VM , i am doing this on single system and i have already run apt-get update and apt-get upgrade and make clean also…

Any other solution sir?

hi sir other solutions for this issue?

Repeatedly asking is not going to help if people haven’t experienced the problem themselves. The simplest solution is it use a supported platform and follow the installation instructions precisely.

Otherwise you are going to have to do more research on how your installation differs from a standard one than anyone on a peer support forum is likely to provide as free consultancy.

https://issues.asterisk.org/jira/browse/DAHLIN-359