Dahdi doesn't work with junghanns quadbri isdn card (hfc 4s)

I’ve tried with AsteriskNOW and Ubuntu Server (with Asterisk, DAHDI Linux and DAHDI Tools 2.2.0from source).

When I run dahdi_hardware system shows this message:
driver should be ‘qozap’ but is actually 'hfc4s8s_l1’
pci:0000:02:02.0 qozap+ 1397:08b4 Junghanns QuadBRI ISDN card

I’ve also installed a TDM400P card with 2 FXO modules but this one works perfectly.

I’ve tried to configure with dahdi_genconf but dahdi only configures TDM400P. With dahdi_scan doesn’t detect isdn card.

What can I do?

Thank you in advance.

you can try to use wcb4xxp for BRI cards.

If this is a four-port BRI card, then you shouldn’t use DAHDI.
DAHDI is for POTS (FXO/FXS) cards.

If I remember correctly, you need the Zaptel sources to build the ISDN modules.

Try googling “zaptel junghans quadbri” or something relevant to that.
I have only intructions for the Digium B410p quadbri (ISDN) pci card.



Looks like I didn’t do my homework right.

I was working since May 2007 with Zaptel and messed up my existing documentation.

At least for the Digium B410p PCI card, you do not need zaptel to configure it.
You can download mISDN seperately and compile it on the box. However, I found out there exists a total of
three methods of doing this :

  1. Do it with mISDN
  2. Do it with “wcb4xxp” (B410P native DAHDI driver)
  3. Do it with “bristuff”

So, the choice is yours.

I will upgrade to the following days, so I will stop using Zaptel (it’s obsoleted) and try to configure my
B410p card with DAHDI (wcb4xxp)
Just an update,