Dahdi does not seem to work properly under Fedora 33 Kernel 5.8.15


I am attempting to install dahdi for a Digium T1/E1 card, specifically a 1TE131F on a Fedora 33 machine. I found a number of older forum posts that suggested that newer kernels should use the next branch of the dahdi-linux repository as opposed to the packaged tar sources in the instructions as I had issues compiling those. I also opted to install libpri from DNF as to avoid any build issues. This install libpri 1.6. I have not installed the tools as of yet nor done any additional configuration since reboot.

For some context, I tried this a few months ago, and everything installed correctly. I wanted to do a quick test, so I cooked up a quick script to open one of the DAHDI channel device files for read/write. This however failed issues. For reference this is the relevant part of my quick test script:

import os
chan = os.open(f'/dev/dahdi/chan/001/001, os.O_RDWR)

Running this script with super user privileges yields an error: [Errno 6] No such device or address: '/dev/dahdi/chan/001/001. Note that all the device files do exist. I also tried an alternative script which attempted to open the control and use ioctls. Unfortunately I don’t recall the exact error that one had, only that it was an ENXIO. At the time, I made several config changes through various files and the dahdi tools, but I did not document them at the time.

So to jump forward. I’ve re-installed dahdi as described above, with a newly imaged system, and have the same issues. No additional configuration has been performed as of yet after the install. I had seen some forum posts with Asterisk errors that looked similar to what my test scripts returned but there were no responses that helped me. Is this a requirements issue? Is dahdi not supported on kernel 5.8.X? What should I do to investigate this further?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.