I was trying to get the sources as the below web manual says but cant reach the with CVSup got this:
cvsup -g -L 2 /usr/src/asterisk-sup
Parsing supfile "/usr/src/asterisk-sup"
Unknown host “

With cvs (anoncvs password)
cvs -z3 login
Logging in to
CVS password:
Unknown host

Thanks in advance,
Daniel Benavides … /x258.html

Digium dropped CVS support about a year ago. it’s SVN now.

Subject says it all. I tried to run the script, it tried to use the CVS repository, which doesn’t exist anymore, and now what?

I could do manually what the script does, but it’s a PITA. What’s the recommended replacement?



As the reply said, Its moved to SVN like many opensorce projects have.


if you don’t know how to modify the script, post the contents of it here and someone will post an updated version for you.

Well, I’m referring to the script you can find at respectively what it downloads when it updates itself.

While I’m aware of the make update in the asterisk Makefile, this script updates all the add-ons, zaptel, etc. in one go.

It seems however (obviously) that this script is somewhat outdated. I’m not “married” to this particular script, and if anyhow possible I want to use a solution that’s “mainstream” and/or “standard”, yet takes out some of the tedium of trying to keep addons, sounds, zaptel, and the main source in sync and updated.

So if anyone has better suggestions than (an edited version) of the above-mentioned script, I’m all ears.


that’s quite a script ! the one i use just wgets the --current.tar.gz, untars and compiles. there’s lots of good stuff in that script, but to be honest, most of the time i make changes to the Makefiles for add-ins, so automating it is never going to be an issue.

as for keeping up with the latest version … sometimes you’re asking for pain !!