Couldn't call Agent and segfault

Hi folks!

I´m having the following problem:

I get the following messages, asterisk get automatically reloaded and agents log out once or twice a day, randomly.

[Jul 4 11:36:25] VERBOSE[30004] app_queue.c: – Couldn’t call Agent/2002
[Jul 4 11:36:29] VERBOSE[30320] logger.c: Asterisk Event Logger Started /var/log/asterisk/event_log
[Jul 4 11:36:29] VERBOSE[30320] config.c: == Parsing ‘/etc/asterisk/asterisk.conf’: [Jul 4 11:36:29] VERBOSE[30320] config.c: == Found
[Jul 4 11:36:29] VERBOSE[30320] loader.c: Asterisk Dynamic Loader Starting:
[Jul 4 11:36:29] VERBOSE[30320] config.c: == Parsing ‘/etc/asterisk/modules.conf’: [Jul 4 11:36:29] VERBOSE[30320] config.c: == Found
[Jul 4 11:36:29] NOTICE[30320] loader.c: 2 modules will be loaded.

Also I get a segfault in /var/log/messages.
Any help will be appreciated!

A crash at this stage loading modules during startup) is usually due to having old modules in the modules directory. If not, and you are using the latest 1.8 series version, you need to google for “asterisk wiki backtrace”, follow the instructions there, and then submit a but report to issues.asterisk.org/jira/

There is no evidence that Asterisk was ever ready to handle calls in your trace.

Thanks for your fast reply.

I`m sorry if I did´nt explain myself well, this crash was after hours of working well, it was NOT at startup.
We are runnig a call center and we get asterisk restarted once or twice a day, but afterwards the system continues to work perfectly.

Thanks!

In that case, you need to turn up the verbosity for the log to be of any use. You should still follow the backtrace and bug reporting procedures.