Asterisk hangs while loading at least one module!

Dear Forum,

I habe a strange problem. For testing reasons , I installed a new Suse 12.1 as an Vmware mashine.
There I compiled die curren 1.8.13 release, without any problems.
make install
make samples

when I now try to start with asterisk -vvvc , it ens up with :
== Parsing ‘/etc/asterisk/modules.conf’: == Found
[Jul 3 18:02:55] NOTICE[10456]: loader.c:1129 load_modules: 139 modules will be loaded.

After about 1 minute i get an segmentation fault.
If I disable the autoload feature in the modules config , asterisk starts without hanging up to "asterisk ready"
But if i load at least one module ( for example load => it hangs again saying: 1 module will be loaded…

After all I tried to install the current 10.x version of asterisk, with the same result.

I read a lot tonight, but didnt find any solution for this strange problem …

the OS installation is completly new , no firewall…

thanks for any suggestion !


Crashes on modules loads generally happen because the module was not built at the same time as the core code. Is there any possibility of that?

Otherwise you will need to produce backtraces, having run menuconfig, and rebuilding, to disable compiler optimisation.