Core Dump -- Asterisk SVN-branch-1.4-r85720

I run 5 Asterisk boxes and this is the first one I’ve seen this happen to. This was an SVN download late last night (Monday). I’m trying to recompile it right now with the current SVN (I see some updates to Zaptel), but I thought I’d post the core data here anyways.

# ls -al /tmp/core* | wc -l 622

Besides a random one here and there, they’re all the same file size.

Core was generated by `/usr/sbin/asterisk -f -vvvg -c'. Program terminated with signal 6, Aborted. #0 0x00cb6402 in __kernel_vsyscall () (gdb) bt #0 0x00cb6402 in __kernel_vsyscall () #1 0x00983c00 in raise () from /lib/libc.so.6 #2 0x00985451 in abort () from /lib/libc.so.6 #3 0x009b91fb in __libc_message () from /lib/libc.so.6 #4 0x009c0f5d in _int_free () from /lib/libc.so.6 #5 0x009c45b0 in free () from /lib/libc.so.6 #6 0x0053dac6 in device_state_thread (data=0x0) at app_queue.c:660 #7 0x080f65eb in dummy_start (data=0x8b73a58) at utils.c:831 #8 0x00ace2db in start_thread () from /lib/libpthread.so.0 #9 0x00a2812e in clone () from /lib/libc.so.6

And full:

code bt full
#0 0x00cb6402 in __kernel_vsyscall ()
No symbol table info available.
#1 0x00983c00 in raise () from /lib/libc.so.6
No symbol table info available.
#2 0x00985451 in abort () from /lib/libc.so.6
No symbol table info available.
#3 0x009b91fb in __libc_message () from /lib/libc.so.6
No symbol table info available.
#4 0x009c0f5d in _int_free () from /lib/libc.so.6
No symbol table info available.
#5 0x009c45b0 in free () from /lib/libc.so.6
No symbol table info available.
#6 0x0053dac6 in device_state_thread (data=0x0) at app_queue.c:660
cur =
sc = (struct statechange *) 0xa95120
#7 0x080f65eb in dummy_start (data=0x8b73a58) at utils.c:831
__cancel_buf = {__cancel_jmp_buf = {{__cancel_jmp_buf = {146225800, 0, -1214760048, -1214762040, 1445195026,
-374031434}, __mask_was_saved = 0}}, __pad = {0xb7983480, 0x0, 0x0, 0x0}}
__cancel_arg = (void *) 0xb7983b90
not_first_call =
ret =
#8 0x00ace2db in start_thread () from /lib/libpthread.so.0
No symbol table info available.
#9 0x00a2812e in clone () from /lib/libc.so.6
No symbol table info available.[/code]

Sadly there are no usefull error messages in the FULL log.

Is the only thing I still have on control-copy from the crash when I tried to restart Asterisk by hand, wondering why it wasn’t running.

Reinstalling the new SVN of zaptel alone seems to have fixed the issue. I guess disregard unless it’s another bug.

This was actually a bug in Asterisk, but it has since been fixed. An update to the latest Asterisk code will fix it. (oops …)[/i]