Connectivity issue with sip

hello all

I am using asterisk 16.8.0 when I create sip accounts my softphone cannot connect to the server but when I use the pjsip driver the connection is established.
here is the error message when the sip is used :
[2020-03-19 05:15:51] NOTICE[1959]: res_pjsip/pjsip_distributor.c:676 log_failed_request: Request ‘REGISTER’ from ‘“101” sip:101@10.225.20.114’ failed for ‘10.225.20.64:53096’ (callid: 102651NTJiYjU4NzRhYWE3ZDUxYTA4NjlkNWNiOWM0ODBhMmU) - No matching endpoint found
[2020-03-19 05:15:51] NOTICE[1959]: res_pjsip/pjsip_distributor.c:676 log_failed_request: Request ‘REGISTER’ from ‘“101” sip:101@10.225.20.114’ failed for ‘10.225.20.64:53096’ (callid: 102651NTJiYjU4NzRhYWE3ZDUxYTA4NjlkNWNiOWM0ODBhMmU) - Failed to authenticate

I do not understand can you help me

A REGISTER request came in for endpoint “101”. No endpoint was found matching that. What is your actual configuration?

you are talking about which configuration that of the users?

The PJSIP configuration. It appears it is either invalid or incorrect for what you are trying to achieve.

when i use the configuration of the users with pjsip the softphone connects without problem but when i create users with this configuration the softphone does not manage to connect.

[101] (template)
Callerid = “John Doe” <101>
Secret = secretjd
Mailbox = johndoe@example.com

That configuration is invalid. With such limited information it reads as if you are trying to use chan_sip configuration directly in chan_pjsip, which does not work.

this is the chan.sip that you want to use.

If you plan to use chan_sip you should disable chan_pjsip first (or get it to use some other port number)

how to disable chan_pjsip

Go through the section “Disabling res_pjsip and chan_pjsip” on this link.