Connect to AsteriskNow from Internet

First of all , good morning to all . My name is Ariel , I’m from Argentina and I tell them I’m dabbling with Asterisk by AsteriskNow .

I mounted a PC version Asterisk 11 in a LAN , and all extensions I have in the LAN using SIP can communicate seamlessly between them. I have run ZOIPER in Andrioid , Linux and some ATA SIPURA SP3000 . All without problems.

Now exploring the possibility of power, with the android and through a data plan to access the server from outside the LAN , which would result very useful , I began to investigate, and opened the ports 5060 and 10000 to 20000 my router, all routed to the LAN IP of my server , I have static public IP , but can not connect from the outside.

If I do a scan to the public IP I get that ports are closed , the nmap to that IP is as follows:

25/tcp open smtp
80/tcp open http
81/tcp open hosts2-ns
587/tcp open submission
8081/tcp open blackice-icecap
8443/tcp open https-alt
10000/tcp open snet-sensor-mgmt
55600/tcp open unknown

In the router I have open ports like this:

Below all this the 5060 Open .

The latter is the range of 10000 to 20000

In AsteriskNow settings it is as follows:

As you can see , it should work … I do not know the why of this problem and hope someone can give me a hand to get ahead with this.

Of course, very grateful.


PS: I apologize for my English , my native language is Spanish and I used the google translator .

First of all don’t do it, you will start getting attacks. If this is just a test box, you can try it but in a production server you should consider how to secure the box before port forwarding traffic from the internet.

You should change your sip options to static ip. In the externip field you fill you public ip and in the localnet you fill you local network range e.g.

If all is working correctly internally, then make sure you hve fowards the ports correctly on your router, a workaround to reduce the hacking attemps it is change the defautl sip port, but other security measures are needed