Configure Music On Hold


#1

Good morning, I’m trying to use music on hold while the other user answers a call, however when calling an extension only the music plays and it never rings,
Thank you.

[internal]
exten => _7XXX,1,Answer()
exten => _7XXX,n,MusicOnHold()
exten => _7XXX,2,Dial(SIP/${EXTEN},20)
exten => _7XXX,3,Playback(/var/lib/asterisk/sounds/es/vm-nobodyavail)
exten => _7XXX,4,VoiceMail(${EXTEN}@main)
exten => _7XXX,5,Hangup()

#2

You want to use the “m” option to Dial, not call MusicOnHold in the dialplan.


#3
exten => _7XXX,2,Dial(SIP/${EXTEN},20,m)

Correct?

WARNING[18289][C-00000000]: app_dial.c:2431 dial_exec_full: Unable to create channel of type 'SIP' (cause 20 - Subscriber absent)

#4

Yes, however you would need to ensure the device is registered and reachable.


#5

Thank you very much, it was a problem with the softphone