Conference recording on

Running Asterisk, Dahdi, Web Meetme 3.1 on CentOS 5.2. FreePBX version 2.5.1.

The problem is that conferences cannot be recorded. The following line is written to the log:

app_meetme.c: No DAHDI channel available for conference, conference recording disabled

Dahdi module is compiled and loaded in asterisk. I’ve tried unloading and loading the module via CLI and works without issue. dahdi_test provides replies without issue such as:

Opened pseudo dahdi interface, measuring accuracy…
99.937% 99.975% 99.935% 99.970% 99.935% 99.970% 99.970% 99.935%
99.970% 99.933% 99.971% 99.935% 99.970% 99.970% 99.935% 99.970%

Only using SIP, no hardware devices. I’m stumped on what to look for now since it appears that dahdi is working. Suggestions?


I just went through this problem last week… had me stumped for about 6 hours!!!

You are missing your dahdi.conf file in /etc/asterisk/. I can 99.9% guarantee it.

i would copy all you .conf files to another directory, do a “make samples”, the copy them back. Once that’s done, you should be able to:

*CLI>dahdi show channels

and see that the dahdi_dummy is loaded.

I figured it was something simple I had overlooked. I’ll give that a try, thanks!

That was it…I copied the asterisk- to /etc/asterisk/chan_dahdi.conf and all worked perfectly. Thanks a ton for the resolution!