Confbridge MOH sounds bad with VLC

Hi all,
I’m using vlc application to get an audio stream and put it into the SIP channels as MOH. This worked when I used meetme but now I’ve moved to confbridge the sound has become really annoying.
my musiconhold.conf file:

application=/usr/bin/vlc-wrapper rtp://@:5004 --sout '#transcode{acodec=ulaw,ab=64,channels=1,samplerate=8000}:std{access=file,mux=raw,dst=-}'

with this, VLC is getting the stream via rtp and transcoding it to ulaw. Then, it outputs the transcoded stream to stdout.

As I said, it used to work properly with meetme but now I can recognize the song in the background but there’s a sound like a “techno kick drum” making it really annoying.

my asterisk versions is asterisk-10.5.0.

any help woud be appreciated!

none’s had this problem?
I didn’t change anything at the vlc part and that’s why I supposed it’s the asterisk part which is wrong…

any help saying where to look or something, please??
thank you!

Six and a half hours is a lot less than 24!

Yes. It is is very likely that no-one reading the forum has attempted to use streaming MoH on confbridge, and even more likely that someone reading the forum in the last six and half hours has not done so.

Your description of the problem suggests that timing slips are occuring because the conference is not using the same timing reference as the audio stream, but I have not looked into how timing is provided for your type of audio stream.

you’re right, sorry! :blush:
I need to get this running as fast as possible and I’m in a hurry …
I’ll have a look in the configurations to see how timing stuff works and I’ll tell you when I get something clear…

Thank you David!

hi again,
I’ve been reading through the asterisk configuration files but I don’t know where to get the information about timing references in confbridge…
where can I find that information?

Thank you!

Have you tried using slin instead of ulaw ?

yes, and the annoying noise has changed a little bit but is still there…
It’s kind of weird, I used the link thor posted a long time ago and it worked… but after some time without caring about it, now it’s not working again… well, it’s working but not as it used to!
it might be a vlc problem? I haven’t changed anything in its configuration but I don’t understand why this is wrong…
were there so many things changed from meetme to confbridge? might be a bug?

sorry if I’m being too tiring and thank you!

Does it help if I say that the music behind that noise is playing at a variable pitch?
How can I know where is confbridge getting the timing?
I tried to set “internal_sample_rate=auto” to 8000 in order to force it to coincide with the actual samplerate but that doesn’t improve anything…

Thanks very much!