Compiling dahdi returns this error, need to solve this

oot@Freepbx-debian6:/usr/src/dahdi-linux-complete-2.7.0+2.7.0/tools# ./configure
checking for gcc… gcc
checking whether the C compiler works… no
configure: error: in /usr/src/dahdi-linux-complete-2.7.0+2.7.0/tools': configure: error: C compiler cannot create executables Seeconfig.log’ for more details

HERE IS MY CONFIG.LOG FILE for what its worth:

[code]This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by configure, which was
generated by GNU Autoconf 2.69. Invocation command line was

$ ./configure

---------

Platform.

---------

hostname = Freepbx-debian6
uname -m = i686
uname -r = 2.6.32-5-686
uname -s = Linux
uname -v = #1 SMP Sun May 6 04:01:19 UTC 2012

/usr/bin/uname -p = unknown
/bin/uname -X = unknown

/bin/arch = unknown
/usr/bin/arch -k = unknown
/usr/convex/getsysinfo = unknown
/usr/bin/hostinfo = unknown
/bin/machine = unknown
/usr/bin/oslevel = unknown
/bin/universe = unknown

PATH: /usr/local/sbin
PATH: /usr/local/bin
PATH: /usr/sbin
PATH: /usr/bin
PATH: /sbin
PATH: /bin

-----------

Core tests.

-----------

configure:2211: checking for gcc
configure:2227: found /usr/bin/gcc
configure:2238: result: gcc
configure:2467: checking for C compiler version
configure:2476: gcc --version >&5
gcc (Debian 4.4.5-8) 4.4.5
Copyright © 2010 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

configure:2487: $? = 0
configure:2476: gcc -v >&5
Using built-in specs.
Target: i486-linux-gnu
Configured with: …/src/configure -v --with-pkgversion=‘Debian 4.4.5-8’ --with-bugurl=file:///usr/share/doc/gcc-4.4/README.Bugs --enable-languages=c,c++,fortran,objc,obj-c++ --prefix=/usr --program-suffix=-4.4 --enable-shared --enable-multiarch --enable-linker-build-id --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --with-gxx-include-dir=/usr/include/c++/4.4 --libdir=/usr/lib --enable-nls --enable-clocale=gnu --enable-libstdcxx-debug --enable-objc-gc --enable-targets=all --with-arch-32=i586 --with-tune=generic --enable-checking=release --build=i486-linux-gnu --host=i486-linux-gnu --target=i486-linux-gnu
Thread model: posix
gcc version 4.4.5 (Debian 4.4.5-8)
configure:2487: $? = 0
configure:2476: gcc -V >&5
gcc: ‘-V’ option must have argument
configure:2487: $? = 1
configure:2476: gcc -qversion >&5
gcc: unrecognized option ‘-qversion’
gcc: no input files
configure:2487: $? = 1
configure:2507: checking whether the C compiler works
configure:2529: gcc conftest.c >&5
/usr/bin/ld: crt1.o: No such file: No such file or directory
collect2: ld returned 1 exit status
configure:2533: $? = 1
configure:2571: result: no
configure: failed program was:
| /* confdefs.h /
| #define PACKAGE_NAME “”
| #define PACKAGE_TARNAME “”
| #define PACKAGE_VERSION “”
| #define PACKAGE_STRING “”
| #define PACKAGE_BUGREPORT “”
| #define PACKAGE_URL “”
| /
end confdefs.h. */
|
| int
| main ()
| {
|
| ;
| return 0;
| }
configure:2576: error: in /usr/src/dahdi-linux-complete-2.7.0+2.7.0/tools': configure:2578: error: C compiler cannot create executables Seeconfig.log’ for more details

----------------

Cache variables.

----------------

ac_cv_env_CC_set=
ac_cv_env_CC_value=
ac_cv_env_CFLAGS_set=
ac_cv_env_CFLAGS_value=
ac_cv_env_CPPFLAGS_set=
ac_cv_env_CPPFLAGS_value=
ac_cv_env_CPP_set=
ac_cv_env_CPP_value=
ac_cv_env_LDFLAGS_set=
ac_cv_env_LDFLAGS_value=
ac_cv_env_LIBS_set=
ac_cv_env_LIBS_value=
ac_cv_env_build_alias_set=
ac_cv_env_build_alias_value=
ac_cv_env_host_alias_set=
ac_cv_env_host_alias_value=
ac_cv_env_target_alias_set=
ac_cv_env_target_alias_value=
ac_cv_prog_ac_ct_CC=gcc

-----------------

Output variables.

-----------------

ASCIIDOC=’‘
BDFARCH=’‘
BDFNAME=’‘
CC=‘gcc’
CFLAGS=’‘
CPP=’‘
CPPFLAGS=’‘
DAHDI_DECLARATION_AFTER_STATEMENT=’‘
DAHDI_DEVMODE=’‘
DAHDI_DIR=’‘
DAHDI_INCLUDE=’‘
DAHDI_LIB=’‘
DAHDI_PINNED=’‘
DEFS=’‘
DOWNLOAD=’‘
ECHO_C=’‘
ECHO_N=’-n’
ECHO_T=’‘
EGREP=’‘
EXEEXT=’‘
FETCH=’‘
GNU_MAKE=’‘
GREP=’‘
HOSTCC=’‘
INSTALL_DATA=’‘
INSTALL_PROGRAM=’‘
INSTALL_SCRIPT=’‘
LD=’‘
LDFLAGS=’‘
LIBOBJS=’‘
LIBS=’‘
LN=’‘
LN_S=’‘
LTLIBOBJS=’‘
NEWT_DIR=’‘
NEWT_INCLUDE=’‘
NEWT_LIB=’‘
OBJEXT=’‘
PACKAGE_BUGREPORT=’‘
PACKAGE_NAME=’‘
PACKAGE_STRING=’‘
PACKAGE_TARNAME=’‘
PACKAGE_URL=’‘
PACKAGE_VERSION=’‘
PATH_SEPARATOR=’:‘
PBX_DAHDI23=’‘
PBX_DAHDI=’‘
PBX_HDLC=’‘
PBX_NEWT=’‘
PBX_USB=’‘
PPPD_VERSION=’‘
SHELL=’/bin/bash’
USB_DIR=’‘
USB_INCLUDE=’‘
USB_LIB=’‘
USE_SELINUX=’‘
WGET=’‘
ac_ct_CC=‘gcc’
bindir=’${exec_prefix}/bin’
build_alias=’‘
datadir=’${datarootdir}‘
datarootdir=’${prefix}/share’
docdir=’${datarootdir}/doc/${PACKAGE}‘
dvidir=’${docdir}‘
exec_prefix=‘NONE’
host_alias=’‘
htmldir=’${docdir}‘
includedir=’${prefix}/include’
infodir=’${datarootdir}/info’
libdir=’${exec_prefix}/lib’
libexecdir=’${exec_prefix}/libexec’
localedir=’${datarootdir}/locale’
localstatedir=’/var’
mandir=’${datarootdir}/man’
oldincludedir=’/usr/include’
pdfdir=’${docdir}‘
prefix=‘NONE’
program_transform_name=‘s,x,x,‘
psdir=’${docdir}‘
sbindir=’${exec_prefix}/sbin’
sharedstatedir=’${prefix}/com’
sysconfdir=’/etc’
target_alias=’’

-----------

confdefs.h.

-----------

/* confdefs.h */
#define PACKAGE_NAME “”
#define PACKAGE_TARNAME “”
#define PACKAGE_VERSION “”
#define PACKAGE_STRING “”
#define PACKAGE_BUGREPORT “”
#define PACKAGE_URL “”

configure: exit 77[/code]

Check your libc-dev and gcc installation or check the pkg_config path.

I checked the libc-dev and got this:

[code]apt-get install libc-dev
Reading package lists… Done
Building dependency tree
Reading state information… Done
Note, selecting ‘libc6-dev’ instead of 'libc-dev’
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libc6-dev : Depends: libc6 (= 2.11.3-4) but 2.17-7 is to be installed
Depends: libc-dev-bin (= 2.11.3-4) but it is not going to be installed
E: Broken packages[/code]

gcc’s installation:

dahdi-linux-complete-2.7.0+2.7.0/tools# apt-get install gcc Reading package lists... Done Building dependency tree Reading state information... Done gcc is already the newest version. 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. root@Freepbx-debian6:/usr/src/dahdi-linux-complete-2.7.0+2.7.0/tools#

and pkg_config, can’t find it

!!help!!

alo, anybody there??

You’ve got a very broken development environment. This isn’t really anything to do with Dahdi. You would have problems building any software for that machine… I would take it up on a general Linux support group,

Ok I will follow your advice, I ’ ve already posted the same issue on general Linux support, then I would like the administrators to close this thread in particular.thanks

Ok I will follow your advice, I ’ ve already posted the same issue on general Linux support, then I would like the administrators to close this thread in particular.thanks[/quote]

I SOLVED THE THING,THE SYSTEM WAS ACTUALLY BROKEN FROM THE BEGINNING BECAUSE FROM THE VERY BEGINNING I WAS TRYING TO COMPILE THE KERNEL WITH THE WRONG FILE, THANKS, THE RIGHT FILE IS linux-source-2.6.32.tar.bz2, NOT, linux-2.6.32.tar.bz2