CLI gibberish -- prompt and input appear to be some sort of unicode characters

Hi Horatio,

Thanks for your help, sorry for the late reply. I’ll have a go at recompiling asterisk in a few days and see how I go.


This problem still exists on fedora25.

rpm -qva|egrep ‘asterisk|libedit’


It’s still the latest (and only) version of libedit available.

Hello Everyone,
Fedora Server 25 fix is right here are

To apply fix.

Install networklab.repo /etc/yum.repos.d
Use dnf

dnf clean all; dnf update asterisk\*; dnf downgrade libedit;

Restart asterisk

systemctl restart asterisk.service

Add exclude line to /etc/dnf/dnf.conf


Hi, just getting to this now. Can you tell me more about the networklab
repo? Is this something you maintain? What are the asterisk changes that
were made here? Is it just for compatibility to fix the libedit problem, or
other more general changes?


Yes our repo is actively maintained by NetworkLab. This particular case we back ported correct version of libedit to fedora 25 and generated new asterisk rpms.

Awesome, thanks so much.

Same Problem here after upgrading Ubuntu LTS Xenial (16.04) to Bionic (18.04) on armhf (raspberry pi 2).
I’m stuck.

Did you try compiling Asterisk without libedit as one user suggested earlier in the thread?

Thanks for the fast reply John. No I didn’t yet… I just saw that the upgrade process didn’t work… some packages left unconfigured or not updated, asterisk among them. Need to fix that first. Will write an update soon.

I think I’ve fixed it by installing the dev lib
apt install libedit-dev


FYI: I had this issue on Rocky8 + Asterisk 11. Removing the libedit-devel package and rebuilding asterisk fixed the issue.

Lots of years later this still happens.
Doing an Elevate from Centos 7 to Almalinux 8 this happens with Asterisk 20.

The solution:

dnf remove libedit -y
dnf remove libedit-devel -y
yum config-manager --set-enabled powertools
dnf install libedit -y
dnf install libedit-devel -y