Centos update broke dahdi

I updated centos from 5.8->5.9 using yum update, and dahdi stopped working, so I started from scratch and did a fresh install on a new machine. Dahdi does not compile on Any of my machines using centos 5.8 then doing a yum update? I tried to do a fresh install of centos5.8 and then try without the update, but it tells me right away it’s not compatable with my kernel… So i do a yum update & then it starts compiling then towards the end it errors. None of the dahdi patches work either when I apply, I still get the same droit, but 1 week ago before 5.9 cents was released the patch worked.

I am anovice, but anyway to get dahhdi to work? Also do I need dahdi for anything?? my only analog line is connected to a backup sip ata device?

What error do you get when you try to build dahdi?

My guess is that you don’t have a kernel-devel package that matches the booted kernel.

After way too much time it is finally working.

The issue is after a 5.9 update or a “YUM UPDATE”

Dahdi compile will error out

Vim /usr/src/dahdi-linux-complete-2.6.1+2.6.1/linux/drivers/dahdi/xpp/xdefs.h

go to line 152 and comment it out with /* */

Then you can build it successfully. There were two boolean def’s in the file right after each other.

This is the link that helped me solve.

I am now running centos 5.9, DIGIUM ASTERISK 10.8, Freepbx 2.8, and no issue.