Cdr_adpative_odbc configured but cdr sql insert never occurs

Hi im trying to get cdr_adaptive_odbc configured on Asterisk 15 for MySql. It seems like everything is configured properly:




enabled => yes
dsn => myappsourcename
username => root
password => *****
pre-connect => yes

Ive configured all my settings for odbc connector for mysql in /etc/obdc.ini . Because asterisk shows successful connection:

CLI> odbc show all

ODBC DSN Settings

  Name:   asterisk-cdr
  DSN:    myappsourcename
    Number of active connections: 1 (out of 1)

Ive even connected succesfully with isql myappsourcename

Again everything seems properly configured, but when i test an answered call. I never see anything about an insert to my call_log table. My table does exist and my column names are named exactly as CDR variables so i dont have to use the alias options in my configs.

I tried enabling regular cdr_odbc to see if that wasnt working either but that seems to work as soon as i enabled it, because i can actually see it run the Insert statement in the asterisk cli. Although it fails with:

[Feb 26 13:39:14] WARNING[1328]: cdr_odbc.c:159 execute_cb: cdr_odbc: Error in ExecDirect: -1, query is: INSERT INTO call_log (calldate,clid,src,dst,dcontext,channel,dstchannel,lastapp,lastdata,duration,billsec,disposition,amaflags,accountcode,uniqueid,userfield,peeraccount,linkedid,sequence) VALUES ({ts ‘2019-02-26 13:38:46’},?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?)

[Feb 26 13:39:14] ERROR[1328]: cdr_odbc.c:188 odbc_log: CDR direct execute failed

Im at least seeing an insert statement with cdr_odbc, but with cdr_adaptive_odbc, i never see anything regarding an insert. Ive also turned on debug logging and still dont see any reference to cdr_adaptive_odbc errors.

Im using Asterisk 15.7.1 on Ubuntu 16.04.

Im not sure what i have misconfigured here and confused on what i should try next since odbc connections seem to be active and i can connect successfully with isql. Im also confused by why cdr_odbc runs the insert but never see anything with cdr_adaptive_odbc. Am i forgetting to enable something somewhere?

this is my working configuration on Ubuntu