Can't send 10 type frames with PJSIP


Every time I make a phone call, I get hundreds of WARNING errors in the Asterisk logs. The call goes through fine, I would just like to know is there a way to stop this. All of my extensions are PJSIP, because that’s the future of Asterisk according to to the internet. I’m running FreePBX v14 with Asterisk 13.17.2.

I’m getting the following WARNING every second of the phone call:

WARNING[13556] [C-0000000e]: chan_pjsip.c844 chan_pjsip_write: Can’t send 10 type frames with PJSIP

Any ideas, please?

Frame type ‘10’ is comfort noise which Asterisk does not support. However as of 13.18.0 this message will be silenced so you won’t see it anymore.


Thank you for the quick response.

Could I ask when the v13.18 update will be available, please?

You mentioned the warning will be silenced, does that mean it will be omitted from the logs?

I’m upgrading our phone system in the office, and we ideally would like to upgrade as soon as possible, however, this issue is going to cause us to postpone it.

Thank you.

The 13.18.0 release is currently in release candidate status and will hopefully be released in the next week. The message will no longer appear in the log.

1 Like

Thank you, much appreciated.

I’ve seen the 13.18.0 update was released yesterday on the 30th October, I ran an update this morning on the 31st, and I’ve seen that I’m still running 13.17.2. I have ran the necessary update commands through FreePBX. Do I need to download from the Asterisk’s website?

We (the Asterisk project) don’t control the release time for FreePBX stuff, so you’d need to ask them when it will be officially available.

1 Like

Thank you. I’ve asked the FreePBX support team when it will be available.

FreePBX has not got back to me just yet. I was curious to know if I could simply use the command ‘asterisk-version-switch’. I’ve seen the options available to me are Asterisk 11, 13, 14 and 15. Could I simply switch versions to either v14 or v15 and will that resolve my problem?

I have no experience with FreePBX so I can’t comment on that. Someone else here may be able to answer, but maybe not.

I appreciate your advice, thank you.

Is has been updated. And I’m no longer receiving the WARNING message. Thank you for your help.

still have WARNING anything i can do ?

Your message is in regards to chan_sip. I don’t think there’s been any changes in that regard.

1 Like

For someone like me still staying on chan_sip and Asterisk 13 version or so, something I fixed on this problem is that on a softphone which is Phoner Lite I changed the config at Codecs tab, where from “no silence detection” changed to “drop silence packets” and the logs on Asterisk CLI : Can’t Send 10 Type Frames With SIP Write are gone — problem solved if you have an Endpoint (SoftPhone) with these features.
It means that in some cases the problem can be solved from endpoint side by selecting the right feature if that is possible for sure.