Cant install libpri 1.4-14 on centos 5.8

Dear all,

After installing using asterisk iso several time, I always ended up destroying my setup everytime updating asterisk via freepbx.

Finally I try to install from basic, I follow … os-58.html.

However I stuck at “make” on libpri installation. Could someone tell me what is my mistake?

Thank you


Here’s the error :

[root@ippbx1 libpri-1.4.14]# make
gcc -g -Wall -Werror -Wstrict-prototypes -Wmissing-prototypes -fPIC -O2 -MD -MT pridump.o -MF .pridump.o.d -MP -c -o pridump.o pridump.c
pridump.c:45:24: error: dahdi/user.h: No such file or directory
pridump.c: In function âpri_openâ:
pridump.c:53: error: storage size of âpâ isnât known
pridump.c:60: error: âDAHDI_GET_PARAMSâ undeclared (first use in this function)
pridump.c:60: error: (Each undeclared identifier is reported only once
pridump.c:60: error: for each function it appears in.)
pridump.c:64: error: âDAHDI_SIG_HDLCRAWâ undeclared (first use in this function)
pridump.c:64: error: âDAHDI_SIG_HDLCFCSâ undeclared (first use in this function)
cc1: warnings being treated as errors
pridump.c:53: warning: unused variable âpâ
pridump.c: In function âpri_bridgeâ:
pridump.c:97: error: âDAHDI_GETEVENTâ undeclared (first use in this function)
make: *** [pridump.o] Error 1

I search google, they said I should installing dahdi-linux-complete first,so I tried but still show some error.

Here’s the error :

[root@ippbx1 dahdi-linux-complete-2.6.1+2.6.1]# make all
make -C linux all
make[1]: Entering directory /usr/src/asterisk/dahdi-linux-complete-2.6.1+2.6.1/linux' make -C drivers/dahdi/firmware firmware-loaders make[2]: Entering directory/usr/src/asterisk/dahdi-linux-complete-2.6.1+2.6.1/linux/drivers/dahdi/firmware’
make[2]: Leaving directory /usr/src/asterisk/dahdi-linux-complete-2.6.1+2.6.1/linux/drivers/dahdi/firmware' make -C /lib/modules/2.6.18-348.1.1.el5/build SUBDIRS=/usr/src/asterisk/dahdi-linux-complete-2.6.1+2.6.1/linux/drivers/dahdi DAHDI_INCLUDE=/usr/src/asterisk/dahdi-linux-complete-2.6.1+2.6.1/linux/include DAHDI_MODULES_EXTRA=" " HOTPLUG_FIRMWARE=yes modules DAHDI_BUILD_ALL=m make[2]: Entering directory/usr/src/kernels/2.6.18-348.1.1.el5-i686’
VERSION /usr/src/asterisk/dahdi-linux-complete-2.6.1+2.6.1/linux/drivers/dahdi/xpp/xpp_version.h

CC [M] /usr/src/asterisk/dahdi-linux-complete-2.6.1+2.6.1/linux/drivers/dahdi/xpp/card_bri.o
In file included from /usr/src/asterisk/dahdi-linux-complete-2.6.1+2.6.1/linux/drivers/dahdi/xpp/xpd.h:26,
from /usr/src/asterisk/dahdi-linux-complete-2.6.1+2.6.1/linux/drivers/dahdi/xpp/card_bri.c:29:
/usr/src/asterisk/dahdi-linux-complete-2.6.1+2.6.1/linux/drivers/dahdi/xpp/xdefs.h:152: error: conflicting types for âboolâ
include/linux/types.h:36: error: previous declaration of âboolâ was here
make[4]: *** [/usr/src/asterisk/dahdi-linux-complete-2.6.1+2.6.1/linux/drivers/dahdi/xpp/card_bri.o] Error 1
make[3]: *** [/usr/src/asterisk/dahdi-linux-complete-2.6.1+2.6.1/linux/drivers/dahdi/xpp] Error 2
make[2]: *** [module/usr/src/asterisk/dahdi-linux-complete-2.6.1+2.6.1/linux/drivers/dahdi] Error 2
make[2]: Leaving directory /usr/src/kernels/2.6.18-348.1.1.el5-i686' make[1]: *** [modules] Error 2 make[1]: Leaving directory/usr/src/asterisk/dahdi-linux-complete-2.6.1+2.6.1/linux’
make: *** [all] Error 2

Solved .
I think the guidance should be change.
It should be :

  1. dahdi-linux

wget … rc1.tar.gz
wget … 6.1.tar.gz

Thanks to all , I will post another question later.