Can't get the a (assitant) extension working

Actually, I can’t get any of the tone controls *, 0 or # during voicemail working. Is there a setting in voicemail.conf or something to make voicemail respond to these keys?

I reduced my dial plan to something very simple for test like:


exten => a,1,VoiceMailMain()

exten => *98,1,VoiceMailMain()

exten => o,1,Dial(${MY_OPERATOR})
same => Hangup()

exten => 102,1,Dial(${OFFICE01},10)
same => n,VoiceMail(102@default,u)
same => n, Hangup()

I get to the voice mail when I dial 102 but none of *, 0 or # create any action. Not even # when trying to get options to finish a message. I can leave a message, send it by email and retrieve it. But no response to the control keys.

Please let me know if you need any other conf settings.



For some reason voicemail.conf wasn’t reloading properly so my exitcontext setting wasn’t loaded. Restarted the core and no problem now.

Also found the the delete setting in [general] doesn’t work. Piped delete=1 to the attach option in the actual vm box and it took.