Can't get my Aastra phone to play nice with asterisk@home


#1

I’m having real problems getting my phone to connect to my asterisk box.

I was able to set the phone up to work generally how I wanted it to originally, using Asterisk@Home and a default configuration (several extensions, 200-203). Each phone could receive and dial out without problems. There was extra functionality missing that I really wanted however, so I decided I would upgrade the phones to the latest firmware, and since that upgrade I have been unable to get the phone to connect to asterisk (they just display ‘No Service’ the whole time, which from my previous setup makes me think it isn’t authenticating properly.

I am still able to get software phones to connect without issue. If anyone has any ideas as to what I should try please let me know…

My setup is generally as follows right now:
Asterisk PBX: 192.168.0.27
Aastra phones: 192.168.0.28 - 192.168.0.30
extensions: 200 - 203


#2

Which Aastra phone? Post your mac.cfg and aastra.cfg


#3

Sorry, I knew I forgot something in this post.

The phone is a 480i CT with firmware version 1.3.

I was able to set up the same phone with older firmware without setting up any of the .cfg files, but have been unable to do the same with the newer firmware.

My aastra.cfg:

dhcp: 1                            # DHCP enabled.

sip silence suppression: 2         # "0" = off, "1" = on, "2" = default

sip proxy ip: 192.168.0.27                   # IP of proxy server.
sip proxy port: 5060             # 5060 is set by default.
sip registrar ip: 192.168.0.27               # IP of registrar.
sip registrar port: 5060         # 5060 is set by default.

sip digit time out: 6             

softkey3 type: speeddial
softkey3 label: CallReturn
softkey3 value: *69
softkey3 states: idle

softkey4 type: speeddial
softkey4 label: Voice Mail
softkey4 value: *89
softkey4 states: idle

softkey5 type: dnd
softkey5 label: 
softkey5 value: 
softkey5 states: idle connected
softkey5 menugroup:


sip digit timeout: 4
sip dial plan: "[2-9]11|9911|1[01]xx|[2-9]xxxxxx|1[2-9]xxxxxxxxx|011x+#|xx*|*xx+#|xxxxxxxxxxxxxxxxx#"

mac config: #nothing here!


#4

It’s not registering because you aren’t telling the phone it’s account for line xx or it’s outbound proxy. Your mac.cfg (note: The filename should be your phone’s MAC ADDRESS.CFG) should look something like this:

dhcp: 1 # DHCP enabled

sip line1 transport protocol: 0
sip line1 proxy ip: 192.168.0.27
sip line1 proxy port: 5060
sip line1 registrar ip: 192.168.0.27
sip line1 registrar port: 5060
sip line1 registration period: 120
sip line1 outbound proxy: 192.168.0.27
sip line1 outbound proxy port: 5060
sip line1 auth name: 200 <- Your extension #
sip line1 password: 1234 <- Your password
sip line1 user name: 200 <- Your extension #
sip line1 display name: Ext.200
sip line1 screen name: Whatever you want for the display

softkey1 type: speeddial
softkey1 label: PickupCall
softkey1 value: *8
softkey2 type: speeddial
softkey2 label: Voicemail
softkey2 value: *97
softkey3 type: speeddial
softkey3 label: speeddial1
softkey3 value: 12125551212
softkey4 type: speeddial
softkey4 label: speeddial2
softkey4 value: 12125551212
softkey5 type: speeddial
softkey5 label: speeddial3
softkey5 value: 12125551212

softkey6 type: speeddial
softkey6 label: DND ON
softkey6 value: *78
softkey7 type: speeddial
softkey7 label: DND OFF
softkey7 value: *79
softkey8 type: speeddial
softkey8 label: CallFwdOn
softkey8 value: *72
softkey9 type: speeddial
softkey9 label: CallFwdOff
softkey9 value: *73

softkey10 type: speeddial
softkey10 label: Weather
softkey10 value: *61
softkey11 type: speeddial
softkey11 label: WakeupCall
softkey11 value: *62
softkey12 type: speeddial
softkey12 label: Time
softkey12 value: *60

softkey14 type: speeddial
softkey14 label: EnableCW
softkey14 value: *70
softkey15 type: speeddial
softkey15 label: DisableCW
softkey15 value: *71
#softkey16 type: speeddial
#softkey16 label: Enable CW
#softkey16 value: *70
#softkey17 type: speeddial
#softkey17 label: Disable CW
#softkey17 value: *71

This is merely a samply mac.cfg file and you need to customize it to your settings


#5

Ok, so with the new firmware I have to do that for each line?
I can handle that :wink:

I’ll give it a shot when I get back home - thanks for the help


#6

You don’t have to have it for each line, the other lines will inherit the first lines settings.


#7

Thank you very much! That config you gave me worked like a charm :smile:


#8

np :wink:


#9

Now on to a trickier question:

I have two of these 480iCT phones, which each support up to 9 ‘line appearences’. They sport four physical ‘line x’ buttons each, and there is an indicator lamp on each one that lights up when that ‘line’ is in use.

Ideally I would like to have the following functionality (but from what I understand this can’t currently be done)

My secretary picks up an incoming call on ‘line 1’ on her phone (ext 200). She puts that call on hold.

I look at my phone (ext 201) and see that the ‘line 1’ lamp is flashing - pickup the call, and am talking to the client without any extra work (like ‘transferring’ the call to my extension).

Is there any way of easily doing something similar to this?


#10

Unfortunately, no.


#11

long(er) version- what you ask is called shared call appearances, which are made possible with SIP-B. Asterisk doesn’t support SIP-B and almost nobody does.


#12

Ok, so how can I have something similar done with transfers?


#13

I’d imagine that since I only have two extensions that I need to hook up to each other, that I should be able to make a ‘transfer call to ext 201’ key, correct?


#14

yes,

Make sure you have the t flag set in the dial command, but I believe these phones should work OK by using the xfer button

rgds


#15

It seems like transfers are an odd thing with these phones, and after reading all the manuals I haven’t been able to figure a way around this, but perhaps someone here knows. :smile:

If I take a call on ext 200, these are the steps I have to take to transfer it to ext 201:

press ‘public’ (this one is the weird one - doesn’t seem necesary)
press 'line x’
dial 201
wait for 201 to answer
press 'xfer’
hang up ext 200

Is there any way to reduce this to something shorter like:
'press xferto201’
hang up ext 200


#16

Press Xfer and then the extension for an attended transfer. Or use # then the extension.

The “public” button is to ENABLE the cordless extension’s ability to pickup on a live call. It is in private mode by default so no one can just pickup the cordless extension on a live call.


#17

I’ve been able to get that to work if it is an incoming call, but not if the call originates as an outgoing call. Is there some special voodoo I need to do to get that working?


#18

I thought it worked fine just by using the xfer button, but I’ll check on our system. We park most calls here though.