Can't get DAHDI to run

I used two methods to attempt to get DAHDI to run

One was following the steps at https://wiki.asterisk.org/wiki/display/DAHDI/Quick+Start+From+Source

No errors in previous steps

“cat /etc/dahdi/modules” shows

Autogenerated by /usr/sbin/dahdi_genconf (Dahdi::Config::Gen::Modules) on Tue Feb 23 12:55:53 2016
If you edit this file and execute /usr/sbin/dahdi_genconf again, your manual change
wanpipe

However once I get to the "dahdi_genconf system"
I get : “Empty configuration – no spans”

I get to the end of the install when I try running

service dahdi start and get “dahdi: unrecognized service”

I have also downloaded
http://downloads.asterisk.org/pub/telephony/dahdi-linux-complete/dahdi-linux-complete-current.tar.gz
Then entered the following:

make
make install
make config

Without any errors.

Then again service dahdi start with same result:

“dahdi: unrecognized service”

Anyone know what is going on?

wanpipe is a Sangoma product. I’d suggest getting support from them.

Which board you are attempting to install? What is the output of lspci? Is that all the contained information in the modules file?

But I am just trying to get DAHDI run independently of any Sangoma product. They can’t help me with DAHDI, an Asterisk product.

lspic produces:

02:00.0 Network controller: Sangoma Technologies Corp. A200/Remora FXO/FXS Analog AFT card

Nothing more in the modules file.

Thanks

I need to note something important.

This is “dahdi-linux-complete-2.11.0+2.11.0”

I regressed back to 2.10, and it works.

I went ahead and file a bug report on this, even though 2.11 is not even available to report as a selection.

Thanks for your time, and responses.

Unfortunately as David said, Sangoma is a different product from digium and it depends from wanpipe, so yes you need to check that “bug” with sangoma. Dahdi are designed for Digiums Cards and other vendors use or modify for its products so its hard to know what s the issue.

Well, the thing is I was also just trying to compile and run DAHDI exclusively of the wanpipe.
And in which it appears 2.11 is bugged.

Thanks

I see, then collect the info, try to reproduce and submit a bug in the JIRA page. That will help a lot of people.

@tcreek, It Looks like DAHTOOL-73 was created for this same issue. However, the output still looks like wanpipe may have already been installed on this system.

To reiterate what I said there, try installing DAHDI in a clean system Centos 6.7 machine (or setup a virtual machine and install it there). I’ll bet money it will work for you and it will remove any issues with a previous wanpipe installation interfering.

1 Like

Unless Wanpipe goes with the basic install of CentOS, then not possible.

Same problem here too. Fist thing after I install updates and tools on centos 7 64 is DAHDI dahdi-linux-complete-current.tar.gz and it fails every time. Even tried installing dahdi without updating centos 7 64 with kernel 3.10.0-229.el7.x86_64, no chance.

make all && make install && make config
make -C linux all
make[1]: Entering directory /usr/src/dahdi-linux-complete-2.11.1+2.11.1/linux' make -C drivers/dahdi/firmware firmware-loaders make[2]: Entering directory/usr/src/dahdi-linux-complete-2.11.1+2.11.1/linux/drivers/dahdi/firmware’
make[2]: Leaving directory /usr/src/dahdi-linux-complete-2.11.1+2.11.1/linux/drivers/dahdi/firmware' You do not appear to have the sources for the 3.10.0-229.el7.x86_64 kernel installed. make[1]: *** [modules] Error 1 make[1]: Leaving directory/usr/src/dahdi-linux-complete-2.11.1+2.11.1/linux’
make: *** [all] Error 2

See my reply in the other thread.