Can't dial out from SIP using CAPI


I’ve been trying to configure my extensions.conf and sip.conf for two days now and I’m pretty sure it’s just a small typo or anything I can’t find by myself.

My setup:

  • Asterisk connected via Fritz! PCI Card to a HiPath 3500 (2 channels)
  • SIP channel to dial out to foreign countries
  • Cisco 7912 attached to asterisk using SIP (in another city)

When I dial extension 85 my Cisco phone is ringing and I can talk and everything works fine. But when I try to dial an extension from the dialplan I never get a connection.

I’ve posted my capi.conf, extensions.conf and sip.conf here:

When dialing out via ISDN I have to dial a 0 to get a line.

Something I notices in the SIP debug is, that my phone always requests numbers like sip:number@domain;user… , when dialing out. Is that right when using a SIP device?

I have not tried the callcentric stuff so far and that’s not so important for me right now. I just want to be able to dial out in the first step. Maybe you find my problem.


Talked to a friend of mine. Solved the issue. I just forgot to tell CAPI the device to use.

exten => _0.,1,Dial(CAPI/contr1/${EXTEN}) was the right command to use.

Thanks anyway.