Can't complete a call with AEX410

I have been trying to figure this out for a while and I think it is time to ask for
help. I am having a hard time getting my analog setup to work. I have an AEX410 installed
on Ubuntu 11.10 server. And here are some of the confige files.

Linux- dmesg
[ 9.974366] dahdi: Telephony Interface Registered on major 196
[ 9.974368] dahdi: Version: 2.6.0
[ 10.010559] wctdm24xxp 0000:03:08.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 11.682052] wctdm24xxp 0000:03:08.0: vpmoct: Detected firmware v1.12 Serial: 5VPMOCT032LF-B DM99136040120
[ 13.128040] wctdm24xxp 0000:03:08.0: Port 1: Installed – AUTO FXS/DPO
[ 13.128043] wctdm24xxp 0000:03:08.0: Port 2: Installed – AUTO FXO (FCC mode)
[ 13.128046] wctdm24xxp 0000:03:08.0: Port 3: Not installed
[ 13.128048] wctdm24xxp 0000:03:08.0: Port 4: Not installed
[ 13.128232] wctdm24xxp 0000:03:08.0: Found a Wildcard TDM: Wildcard AEX410 (0 BRI spans, 2 analog channels)
[ 13.198365] dahdi_transcode: Loaded.
[ 13.230442] INFO-xpp: revision Unknown MAX_XPDS=64 (8*8)
[ 13.230450] INFO-xpp: FEATURE: with PROTOCOL_DEBUG
[ 13.230492] INFO-xpp: FEATURE: with sync_tick() from DAHDI
[ 13.232314] INFO-xpp_usb: revision Unknown
[ 13.232399] usbcore: registered new interface driver xpp_usb
[ 18.784004] eth1: no IPv6 routers present


description=Wildcard AEX410
devicetype=Wildcard AEX410 (VPMOCT032)
location=PCI Express Bus 03 Slot 09

I have this pasted at the bottom of chan_dahdi.conf file

;General options
usecallerid = yes
hidecallerid = no
callwaiting = yes
threewaycalling = yes
transfer = yes
echocancel = yes
echocancelwhenbridged = yes
rxgain = 0.0
txgain = 0.0
;FXS Modules
group = 1
signalling = fxo_ks
context = Incoming
channel = 1
;FXO Modules
group = 1
echocancel = yes
signalling = fxs_ks
context = Internal
channel = 2


exten => 1,1,Dial(DAHDI/1-1)
exten => 1,2,Voicemail(1000,u)
exten => 1,102,Voicemail(1000,b)
exten => 8500,1,VoiceMailMain
exten => 8501,1,MusicOnHold
exten => _9.,1,Dial(DAHDI/g1/www${EXTEN:1})
exten => _9.,2,Congestion

exten => s,1,Answer(DAHDI/2-1)
exten => s,2,playback(hello-world)
exten => s,3,hangup()

  1. I have dial tone on the FXS port but I can’t call out.
    I get a fast busy tone after the first digit I enter.
  2. When I call in I hear a ring back tone but the phone is not
    ringing. The call does not get answered or hangup.
    At the Asterisk CLI there are no error messages.
    I have been at this for two weeks I am not sure if I have
    provided all the info to get help please let me know.

channel = should be channel =>

You appear to have both FXS and FXO lines in group 1

Even if there are no obvious error messages, verbose level CLI output, during a call, is still important.

I am very new at this please clarify.

“You appear to have both FXS and FXO lines in group 1”

Do you mean I need to move the port module FXS or FXO
on the physical card or just the designation in chan_dahdi.conf ?

Thank you for your response.

[quote][color=#FF0000]group = 1[/color]
signalling = [color=#FF0000]fxo_ks[/color]
context = Incoming
channel = 1
;FXO Modules
[color=#FF0000]group = 1[/color]
echocancel = yes
signalling = [color=#FF0000]fxs_ks[/color][/quote]

Thanks. I didn’t think of the relevance of the group # because I wasn’t
seeing any erros. I will let you know as soon as I try it out.

I changed chan_dahdi.conf to look like this but it hasn’t worked.
How is the group # determined or assigned? I have tried using
different #'s with no luck.

I am stuck please help.

;General options
usecallerid = yes
hidecallerid = no
callwaiting = yes
threewaycalling = yes
transfer = yes
echocancel = yes
echocancelwhenbridged = yes
rxgain = 0.0
txgain = 0.0
;FXS Modules
group = 1
signalling = fxoks
context = Incoming
channel => 1
;FXO Modules
group = 2
echocancel = yes
signalling = fxsks
context = Internal
channel => 2

Group numbers must match the group number in the dial string, if you use them there, which you do.

Basically all I did was cut and paste the sample configurations provided
in the manual for the card I just baught from Digium,which they say should
work. It’s not working for me. May be it is time to give up.

If you bought it from Digium, you should be using Digium’s commercial support help desk, not the open source peer support forum. … hp?tab=log

Or telephone to:

+1 256 428 6000

Malcom, could you note that it wasn’t at all clear to me from the web site that commercial support was offered for anything other than switchvox. There needs to be a third support category for Digium telephony cards.

We’ve got a bit picture of cards right here:

That’s from:

And when you click on the Asterisk support bits you end up here: … solutions/

where there’s a Scope of Support defined in the table for telephony cards.

We’ve just got a lot of people that don’t read (manuals, anyone, Bueller?) :frowning:

I’ve also added a Sticky (maybe a few people will read it) to the Support forum here: