Cannot make config in Asterisk 18.12.1

Hi, I’m trying to install Asterisk 18.12.1 in a Centos 9 environment. I’ve done make install and make samples successfully, but when I run make config I got the following error:

[hfandrade@srvvoz1 asterisk-18.12.1]$ sudo make config
/bin/sh: line 7: /sbin/chkconfig: No such file or directory
make: *** [Makefile:898: config] Error 127

Could you help me, please?

Try running Asterisk manually (‘sudo asterisk’ or ‘sudo asterisk -cvvv’ [for CLI]) to see if it runs properly.
The ‘make config’ command sets up Asterisk to automatically run during reboot. That’s all it does and it is optional.

But if chkconfig isn’t supported, the startup script could be for the wrong startup system. You may find that there is an alternative script that will work with the new startup system, but you may have to custom one or create your own.

The startup scripts do more than starting Asterisk, e.g. they copy core files after a crash and do an automatic restart, so running without one is only a temporary solution.

I can’t get past the paywall, but it looks like the lack of chkconfig in RH9 is being treated as a bug in RH9. I don’t know whether that would apply to CentOS, as well, but I guess the point is that CentOS comes without support and telling you would be support.

However, there is a chkconfig package for Centos9, and the above is a few months old, so you might want to check whether you are fully up to date, and whether the package is actually installed:

https://centos.pkgs.org/9-stream/centos-baseos-x86_64/chkconfig-1.20-2.el9.x86_64.rpm.html

What chkconfig does is enable the startup script to be run in particular run levels (it looks like all but single user mode), and also makes sure they are run at the correct point in the startup and shutdown sequences.

My guess is [yum|drn] install chkconfig may do the trick, but shouldn’t a Centos9 install be using systemd?

If you go the ‘runlevels’ path, 2-5 should be good since 1 = single user and 6 = reboot.

Sorry. Should be dnf.

Hi, Problem fixed. I’ve only done “yum install chkconfig”. And then “make config” successfully! :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.