Installing on RHEL 9


I have installed Following version of Redhat:

Red Hat Linux release 9 (Shrike)

Downloaded Asterisk Tarball from following link : … 4.4.tar.gz

gunzip asterisk-1.4.4.tar.gz

Note – tar -zxvf gives following error
gzip: stdin: not in gzip format
tar: Child returned status 1
tar: Error exit delayed from previous errors

So tried this tar -xvf asterisk-1.4.4.tar

cd asterisk-1.4.4.tar make clean make

[root@localhost asterisk-1.4.4]# make
**** The configure script must be executed before running 'make'.
make: *** [makeopts] Error 1

Please help me to resolve this issue, or post the step by step instruction to get asterisk successfully installed on my box.


Why RedHat 9? It is very old. Anyways, you must run “./configure” before “make”.

As per your suggestion i run

./configure command giving following output

[root@localhost asterisk-1.4.4]# ./configure
checking build system type... i686-pc-linux-gnuoldld
checking host system type... i686-pc-linux-gnuoldld
checking for gcc... no
checking for cc... no
checking for cl.exe... no
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.


There is one output text file