Can t start Asterisk

When i m doing the command
asterisk -cvvvv i ve got this error someone any idea i tried to check if there is no same port in conflict it s not the case

WARNING[28410]: manager.c:3159 init_manager: Unable to bind socket: Address already in use

Thanks for ur help

Try netstat -a and look for 5038 in use ??? As first guess ?

i tried it but i ve got the same error i don t know whats wrong

nothing is using the port 5083 with netstat and i changed the value of the port

C&P your output from netstat -tap

Try changing the port number in manager.conf

i checked my netstat -tap

tcp 0 0 localhost:ipp : LISTEN 5236/cupsd
tcp 0 0 chasles-PC.local:41775 by1msg3093117.phx.:msnp ESTABLISHED 6997/pidgin
tcp 0 0 chasles-PC.local:57235 cs123.msg.mud.yaho:mmcc ESTABLISHED 6997/pidgin
tcp 0 0 chasles-PC.local:43987 TIME_WAIT -
tcp 0 0 chasles-PC.local:49043 mg-in-f125.:angry:mpp-client ESTABLISHED 6997/pidgin
tcp 0 0 chasles-PC.local:55795 a4.bos.providesuppo:www TIME_WAIT -
tcp 0 0 chasles-PC.local:49926 TIME_WAIT

and the port is not in use.
Maybe it s because my account doens t have enough right to launch it? i m using ubuntu 8 and also a non root account.
Thanks for every kind of help

What does your manager.conf look like? Do you actually need this or is just asterisk just trying to load it automatically? If you don’t need it then just disable the manager module in modules.conf

this is my manager.conf

; AMI - The Asterisk Manager Interface
; Third party application call management support and PBX event supervision
; This configuration file is read every time someone logs in
; Use the "manager list commands" at the CLI to list available manager commands
; and their authorization levels.
; "manager show command <command>" will show a help text.
; ---------------------------- SECURITY NOTE -------------------------------
; Note that you should not enable the AMI on a public IP address. If needed,
; block this TCP port with iptables (or another FW software) and reach it
; with IPsec, SSH, or SSL vpn tunnel.  You can also make the manager 
; interface available over http if Asterisk's http server is enabled in
; http.conf and if both "enabled" and "webenabled" are set to yes in
; this file.  Both default to no.  httptimeout provides the maximum 
; timeout in seconds before a web based session is discarded.  The 
; default is 60 seconds.
displaysystemname = yes
enabled = yes
webenabled = yes
port = 8088
httptimeout = 60

; a) httptimeout sets the Max-Age of the http cookie
; b) httptimeout is the amount of time the webserver waits 
;    on a action=waitevent request (actually its httptimeout-10)
; c) httptimeout is also the amount of time the webserver keeps 
;    a http session alive after completing a successful action

bindaddr =
;displayconnects = yes
; Add a Unix epoch timestamp to events (not action responses)
;timestampevents = yes

secret = frere250
; If the device connected via this user accepts input slowly,
; the timeout for writes to it can be increased to keep it
; from being disconnected (value is in milliseconds)
; writetimeout = 100
; Authorization for various classes 
read = system,call,log,verbose,command,agent,user,config
write = system,call,log,verbose,command,agent,user,config

i can t remove it from my modules …thanks for ur help i m really blocked.

Hmm, maybe it’s a firewall/selinux issue?

Try shutting down iptables (if safe to do so)

Also, manager config changes don’t tend to be read on asterisk restarts so do a complete shutdown instead.

You have 8088 listed as the binding port.

Try setting back to 5038 if you can. You might have something else set that.

Edit manager.conf and set port =5038

then restart ans see what happens.