Calling OpenPhone/H.323


#1

I have installed an Asterisk 1.0.9 server running on Debian Sarge and got everything working nicely with SIP extensions, one TDM phone and FWD IAX service. I have also been successful in configuring oh323 to the point that I can make calls into the * server but this is where my problem begins.
Firstly, using OpenPhone to test I found that all calls I make will default to the “s” extension with the following message on the * server:

Connected to Asterisk 1.0.9-BRIstuffed-0.2.0-RC8h currently running on rapid (pi
d = 6006)
Verbosity is at least 17
== Starting OH323/R19550 at voip-h323,9612,1 failed so falling back to exten ‘
s’
== Starting OH323/R19550 at voip-h323,s,1 still failed so falling back to cont
ext ‘default’
– Executing Answer(“OH323/R19550”, “”) in new stack
– Executing Dial(“OH323/R19550”, “Zap/2|30|tr”) in new stack
– Called 2
– Zap/2-1 is ringing
– Zap/2-1 is ringing
– H.323 call ‘ip$192.168.2.125:1067/19550’ cleared, reason 4 (Cleared by re
mote user)
– Hungup ‘Zap/2-1’
== Spawn extension (default, s, 2) exited non-zero on ‘OH323/R19550’
– Hungup ‘OH323/R19550’

I assume the reason for this is that the OH323 extension is not registered and therefore is being directed to the default answer point, a feature I like and don’t want to change.
My question is how do I configure OH323 extensions so that they register and are then allowed to make other calls?
The second problem is that I am not able to make calls out to the OH323 extension and can’t seem to find any information that will assist me in configuring oh323 extensions. I can call the SIP extensions without any problems and tried to follow the same theory of setting up SIP extensions with the oh323 extension but no luck.

Any help or direction greatfully appreciated.
Gerry

P.S.: I have also install gnugt and * and the client are able to register with it…not sure how that helps the situation any, just thought it might be usefull information for you guys.

Thanks in advance guys.