CallerID with Wildcard TDM400P

Hi all,
I have a question about the CallerID from a call trhough Analog PSTN Line !
How can I get, for example, my GSM Modile’s number on my SIP phone ?

I tried this in zapata.conf :

usecallerid=yes cidsignalling=bell cidstart=ring

With this in extensions.conf :

exten => s,1,Answer(1)
exten => s,2,Wait(1)
exten => s,3,NoOp(CallerID=${CALLERID})
exten => s,4,Hangup()

Here is the result :

 -- Starting simple switch on 'Zap/1-1'
Feb 27 11:07:48 NOTICE[10708]: chan_zap.c:6073 ss_thread: Got event 18 (Ring Begin)...
Feb 27 11:07:48 ERROR[10708]: callerid.c:276 callerid_feed: fsk_serie made mylen < 0 (-8)
Feb 27 11:07:48 WARNING[10708]: chan_zap.c:6105 ss_thread: CallerID feed failed: Success
Feb 27 11:07:48 WARNING[10708]: chan_zap.c:6149 ss_thread: CallerID returned with error on channel 'Zap/1-1'
    -- Executing Answer("Zap/1-1", "1") in new stack
    -- Executing Wait("Zap/1-1", "1") in new stack
    -- Executing NoOp("Zap/1-1", "CallerID=") in new stack
    -- Executing Hangup("Zap/1-1", "") in new stack
  == Spawn extension (default, s, 4) exited non-zero on 'Zap/1-1'
    -- Hungup 'Zap/1-1'

Any Help ???

Are you sure you need cidsignalling and cidstart for TDM cards? Does the card catch numbers other than calls from GSM? I skipped all caller ID related parameters in zapata.conf, yet caller ID is delivered correctly.

Thanks for your reply,
I tried only with

usecallerid=yes in zapata.conf

I don’t have the Error message anymore, but I still get “asterisk” as CallerID on my SIP Phone…

Then in sip.conf,

[general] callerid=my asterisk

Not sure if this is supposed to be but it works for me.

Yes but I need the GSM Number who is calling to be the callerid !
:question: :exclamation:

shouldnt you then do callerid=asreceived?

Yes, I tried… But I am still getting “asterisk” instead of my Mobile Number !

Are you sure this line has CID on it?

I also use the same case when I do this

exten => s,3,NoOp(CallerID=${CALLERID})

like this
exten => s,4,Noop(CALLERID=${CALLERID(all)})
exten => s,5,Noop(CALLERID(name)=${CALLERID(name)})
exten => s,6,Noop(CALLERID(number)=${CALLERID(number)})

Not sure if it really matters or not…

Yep… same thing, I tried all the CallerID Variable… Num, Name etc…

Need some clarification. So in sip.conf your have “callerid=asreceived” but your SIP phone displays “asterisk”?

To avoid complexity, my zapata.conf and sip.conf are built from scratch with minimum elements.

; Build a poor man's zapata.conf from scratch [channels] ; Here's the FXO group - we've got only one channel group = 1 context = pstn ; use fxs signaling on FXO signalling = fxs_ks channel => 4

; a poorman's sip.conf [general] ; srvlookup = yes bindport=5060 bindaddr= context = sip callerid = My Asterisk

I notice that before I put callerid= in sip.conf, Asterisk automatically assigns “Asterisk” as value, and passes it to bridged calls. But when I specify a callerid (whatever the value), CID from Zap channel gets passed.

ok fine, if I set callerid=Test, i get “Test” on the phone, but what I want is the Mobile’s Number from where the call is coming (FXO) !
i.e :
Mobile Number : 00971507486878 (UAE)

When I call the PSTN in my office, I get the IVR, then I dial 3000 which is my extension, on the SIP Phone, I would like to see : +97107486878 and not Test or My Asterisk !

:question: :confused:

Ok here is may be why it doesn’t work

From zapata.conf :

; CallerID can be set to “asreceived” or a specific number if you want to
; override it. Note that “asreceived” only applies to trunk interfaces.[/quote]

It’s an Analog Line, not a trunk-line !

But I don’t understand… From Mobile to Mobile, you get the CallerID.
Asterisk doesn’t support it ???

We have assumed you are using a REAL card, is this a x100p or what??

Real Card ??

The card I am using is Wildcard TDM400P REV I

Ok Just making sure…

Where are you?? (US / UK / AU)

UAE - Dubai :wink:

Looks like the card couldn’t detect CallerID. Two possibilities: line does not deliver, or protocol mismatch. Any way to test the line itself? (Like using a regular callerID phone.) Make sure you load the right zone. There are indeed different ways to deliver caller ID over analogue lines. Listening to chirp using ztmonitor might help determine timing of caller ID delivery.

Another possibility is a faulty card. Because Digium offer installation assistance at basic level, you may try to call them to get some idea. (CallerID could qualify as an installation issue.)

Maybe this…
Do you know what the settings are for MIddle-Est ? United Arabs Emirats

I found that here:

But i try the “ae” code in zaptel.conf, it tells me

I think it’s because there is nothing about “ae” code in the indications.conf…
I have googled but i don’t find it…
Any clues ?