CALLERID trouble


#1

Hello all, I am setting up an asterisk server (Version 1.2.4) and am running into a problem having CLID. Incoming call from the PSTN doesn’t show the callerid. I am sure the caller ID is transmitted from my telco, since I receive the caller ID correctly if I connect my phone directly to the phone line.
Below is my zapata.conf, as you can see I’ve got a Wildcard TDM400P with one FXO and one FXS module.

[channels]
usecallerid=yes
hidecallerid=no
callwaiting=no
threewaycalling=yes
transfer=yes
echocancel=yes
echotraining=yes
cidsignalling=bell
cidstart=ring

; define channels
signalling=fxo_ks
context=internal ; Points to the “internal” context of your extensions.conf
channel => 1

signalling=fxs_ks
callerid=asreceived
context=incoming
channel=> 2

Any suggestion ?


#2

if you want callerid you must dial with “o” option . like this:
exten => 1,1,dial(sip/3029,o)

and maybe Wildcard TDM400P has no callerid option in it…


#3

This can’t be correct. I have the same card and have never had a problem, and I don’t do any hacks with the Dial() command. I’m using AAH2.5, so maybe there’s a difference there, but my automatically generated zapata-auto.conf file says this:

; Note: this is a trunk. Create a ZAP trunk in AMP for Channel 4
context=from-pstn
group=0
channel => 4

note the context is ‘from-pstn’ not ‘incoming’. hmmm…