Call ringing directly to extension for +1 days

We have a call that is not in any queue, but is ringing a direct extension, and has been for more than a day. I guess this is a Phantom Call?

Is there a way, either in FOP, command line, or sql query to delete this call?

We prefer not to reboot the server in the middle of the day, and we don’t want to wait until tonight.


It depends what has actually locked up. E.g., if it is a SIP call, it could be the phone.

If an Asterisk channel has failed to hangup, you should be able to use the CLI to clear it, but if it is the device level that is still ringing, but the channel is not up, that may not be an option.

Records are consistently being created in the cdr table for this call and extension. So, I am thinking it is the system.

Would you mind letting us know what command line we could run?

You can do a ‘core show channels verbose’ or ‘core show channels concise’ on the Asterisk Console

Once you identify the channel you need to kill you should be able to do either a 'soft hangup ’ or 'hangup request ’ depending on your asterisk version.

If CDRs are being created, it is the device that is locking up, as the CDR will not be output until the call ends.

First, thank you and david551, for quick responses. We are using v11.25.1
I am getting an error that neither command exists.

Thanks. We are going to reboot the phone and see if that allows us to pick up the call, so we can hang it up properly.

Are you sure you issued the commands at the asterisk CLI prompt?

If the device is locked up, there will be no call to complete, and rebooting it will clear the error.

Note that ring trip is done within the destination device on with SIP, so if picking up the phone is not terminating the ringing, that is definitely a device lock-up problem.

Awesome… As soon as the Tech is off the phone we are going to reboot and see what that does.

Thanks for the prompt responses!

Rebooting the phone didn’t work. The phone can pick up other calls, however in FOP we still see it ringing. It does not actually ring the phone. It just appears as ringing in FOP, and records are being created in cdr.

I tried “soft hangup”, but I still get a “No such command” error.

And, neither does “hangup request”

Try a double tab at the console, see what the CLI will offer you.

I haven’t used Asterisk 11 in a few years, My memory is rusty as to what the syntax is sorry.

So the phone wasn’t ringing, it is just Asterisk that thought it was ringing?

The command you actually want is channel request hangup, see: or use the “help” command at the CLI.

I did a little searching and found this: channel request hangup .

But, I am not sure what it considers the channel.

On my backup server I am seeing this:

However, using 15251 as the channel comes back with an error “15251 is not a known channel”.

When I query cdr I get the following data

SELECT * FROM cdr WHERE dstchannel LIKE ‘%15251%’;

  • channel column = SIP/1051-0001524f
  • dstchannel = SIP/Windstream-00015251

I have tried every variation of these strings, but I still get the “…not a know channel” error.

Just saw this… thanks.

As I said before, the CDR implies the channel was about to terminate. At the moment it seems likely that the device state has got upset, and there is neither an Asterisk channel (which you can hangup from the CLI) or a SIP channel, associated with it.

In that case, the only remaining option is to delete and re-add the device. If you are using sip.conf, removing it from the file, then doing sip reload, should not disturb any other sip device.

There is a slight risk that you have a limited deadlock, in which case the sip reload might hang.

Can this be done through FreePBX?

For FreePBX peer support you would need We are not experts on its limitations. My guess would be that it can be done.

Thank you. I will try there. This is above me… I do not think we are using the conf file because the one we have is generated by FreePbx.

Thanks you for all your help.