Call parking for soft phones

Hello,
I’m trying to make a call parking by using 3 different soft phones. Only 1000 extension have the possibility to transfer a call. When I am in call with 1000 and I try to press #100 nothing happens.

[featuremap]
blindxfer = #1
atxfer = *2
parkext => 300
parkpos => 301-320

Part from extensions.conf for parking calls
include => parkedcalls
exten => i,1,Playback(pbx-invalidpark)
exten => i,2,Hangup

what is your parkcall feature configured as in features.conf?

Default is #72

Do you have the ‘k’ option in your Dial strings?

Hi,

I set up #72 in features.conf, but still not working. Bellow you can find my extensions.conf for parking calls, res_parking.conf and feature.conf. Can you help me and tell me what I’ve done wrong? Also, I receive the following error about the contxet parkedcalls.
WARNING[2166]: pbx.c:8691 ast_context_verify_includes: Context ‘internal’ tries to include nonexistent context ‘parkedcalls’

extensions.con
[general]
static=yes
writeprotect=n

[internal]
exten => 1000,1,Dial(PJSIP/1000,20,T)
same => n,Answer()
same => n,Hangup()

exten => 1020,1,Dial(PJSIP/1020,20,T)

include => parkedcalls
exten => 1001,1,Dial(PJSIP/1001,20,K)

feature.conf
[featuremap]
blindxfer = #1
atxfer = *2
parkcall => #72

res_parking.conf
[general]
parkext => 700
parkpos => 701-709
context => parkedcalls

Thank you.

You won’t be able to park calls to either extension 1000 or 1020 with that configuration.

The person calling extension 1001 will be able to park calls to 1001.

Sorry for bothering again.Every time i try to call from 1020 to 1001, when 1001 answer, the calls stops and in CLI I have the following errors:

WARNING[2330]: pbx.c:8691 ast_context_verify_includes: Context ‘internal’ tries to include nonexistent context ‘parkedcalls’
== Setting global variable ‘SIPDOMAIN’ to ‘192.168.43.17’
[Feb 3 20:51:27] ERROR[2452][C-00000009]: bridge_basic.c:381 builtin_features_helper: Channel PJSIP/1020-00000010: Requested DTMF feature parkcall not available.

Until you enable that option in the Dial string for extension 1001 you will not be able to park the call.

I have indicated so previously.

Sorry, but I don’t know what you mean by k option in dial string. It’s not the K from exten => 1001,1,Dial(PJSIP/1001,20,K) ?

No, it’s not.

‘k’ vs ‘K’

You were setting the ‘K’ option which would allow the person calling to park the call, not the ‘k’ option which allows the person who is being called to park the call.

Thank you. I tried also with ‘k’ option for 1001, but I have the same errors, and also with this option when I call from 1020 to 1001 and 1001 answer, the call stops.

What do you mean by ‘the call stops’ ?

Show me a log of your console when calling from 1020 to 1001.

Hi,

This is the log when I call from 1020 to 1001.

Setting global variable ‘SIPDOMAIN’ to ‘192.168.43.17’
[Feb 4 19:59:58] ERROR[2442][C-00000001]: bridge_basic.c:381 builtin_features_helper: Channel PJSIP/1001-00000001: Requested DTMF feature parkcall not available.
== Spawn extension (internal, 1001, 1) exited non-zero on ‘PJSIP/1020-00000000’

And bellow are the configuration files.
[general]
static=yes
writeprotect=n

[internal]
exten => 1000,1,Dial(PJSIP/1000,20,T)
same => n,Answer()
same => n,Hangup()

exten => 1020,1,Dial(PJSIP/1020,20,T)
same => n,Answer()
same => n,Hangup()

include => parkedcalls

exten => 1001,1,Dial(PJSIP/1001,20,k)
same =>n,Answer()
same => n,Hangup()

feature.conf
[featuremap]
blindxfer = #1
atxfer = *2
parkcall => #72

res_parking.conf
[general]
parkext => 700
parkpos => 701-709
context => parkedcalls

Hello,

Can you help me?
Thank you.