Bug: SayPhonetic() does not work unless proceeded by silence

The following code does not work; the phonetic alphabet is not spoken:

exten => 89,1,SayPhonetic(tu)
exten => 89,n,Hangup()

The following code does work: I hear the audio

exten => 89,1,Playback(silence/1)
exten => 89,n,SayPhonetic(tu)
exten => 89,n,Hangup()

Output (verbose=5) is different. With no “silence,” we get:

  == Using SIP RTP CoS mark 5
    -- Executing [89@public:1] SayPhonetic("SIP/123.45.67.890-00000104", "tu") in new stack
    -- <SIP/123.45.67.890-00000104> Playing 'phonetic/t_p.gsm' (language 'en')
    -- <SIP/123.45.67.890-00000104> Playing 'phonetic/u_p.gsm' (language 'en')
    -- Executing [89@public:2] Hangup("SIP/123.45.67.890-00000104", "") in new stack
  == Spawn extension (public, 89, 2) exited non-zero on 'SIP/123.45.67.890-00000104'

With silence, we pass “probation”:

  == Using SIP RTP CoS mark 5
    -- Executing [89@public:1] Playback("SIP/123.45.67.890-00000105", "silence/1") in new stack
       > 0x7f98fc057df0 -- Probation passed - setting RTP source address to 123.45.67.890:50014
    -- <SIP/123.45.67.890-00000105> Playing 'silence/1.gsm' (language 'en')
    -- Executing [89@public:2] SayPhonetic("SIP/123.45.67.890-00000105", "tu") in new stack
    -- <SIP/123.45.67.890-00000105> Playing 'phonetic/t_p.gsm' (language 'en')
    -- <SIP/123.45.67.890-00000105> Playing 'phonetic/u_p.gsm' (language 'en')
    -- Executing [89@public:3] Hangup("SIP/123.45.67.890-00000105", "") in new stack
  == Spawn extension (public, 89, 3) exited non-zero on 'SIP/123.45.67.890-00000105'

I’m running Asterisk 11.13.1~dfsg-2+b1, via the Debian stable repository.

Your connection doesn’t support early media (you might need Progress for that). Playback, by default, answers the call.

SOLVED.

You’re correct: I replaced the initial Playback() with Answer() and this worked just fine.

Thank you very much.