Bug - Asterisk not propagating ptime in pass-through

I’m using AudioCodes VoIP boxes in our system, with Asterisk as call router. I’m using G723.1, with asterisk configured in pass-through mode. I’m also using a proprietary AudioCodes extension to G723.1, which allows larger frame sizes (60msec and 90 msec). The AudioCodes boxes using the ptime parameter in their SIP INVITE messages.

Unfortunately, Asterisk is discarding that parameter when it sends INVITE messages to the destination, which forces them to default back to the 30msec frame size.

Is there some way I can resolve this omission?? If not, can we modify Asterisk so that it does propagate the “a=ptime:90” parameter??




Is this supposed to be a hint of something?

Well, I dug into the source code, and it appears that Asterisk never generates the ptime argument at all. So I hacked our copy to always add the ptime command (since we always use that coding rate), and that got our system running.

have you posted this, and the fix, to bugs.digium.com ?

hmmm… no, I hadn’t posted to that address, I didn’t realize it existed!! I will do so, however.

Of course, the solution we used here is not a general-purpose solution, it’s specific to our standard usage, but I’ll pass it to them anyway, just for guidance.