Blind Transfer Not Working

We are using Cisco 7941 phones and have noticed when you transfer a call to another phone, the caller ID is the extension number of the phone that transferred the call instead of the actual caller. We have tried firmware 8.5.4 through the latest 9.0.3 and have had the same result. It looks like Cisco combined the blind transfer and attended transfer capabilities with the 7941 because there is only one soft key to press now. Before, on the 7940, there was a transfer and blind transfer soft key which worked perfectly. Has anyone else run into this? We are running Asterisk 1.6

Your analysis sounds right. Based on how they work with skinny, I would say that Cisco only does attended transfers. That means that the callee doesn’t know that there is a transfer until the caller id has already been set (Asterisk doesn’t support updating the caller id on an existing call).

SIP attended transfers are done as a new call, and then an instruction to join the old call to it. Asterisk handles that instruction internally, so there is no new call to the transfer destination, so there is no CLID update.

Connected Line updates are part of 1.8 for SIP and ISDN (Q.SIG on EuroISDN links).