Blacklisted numbers go to silence and don't disconnect

Here’s the story, I’ve got freepbx & asterisk on another box, and blacklist works. The PC I want to run asterisk, freepbx, and mythtv as the dedicated server is the problem box that blacklisted goes to silence.

I used the pc that blacklist works on and have marked the sections of where the non-working pc stops in its tracks when trying blacklist:

== Parsing ‘/etc/asterisk/asterisk.conf’: Found
== Parsing ‘/etc/asterisk/extconfig.conf’: Found
Connected to Asterisk 1.4.22 currently running on KG (pid = 6797)
Verbosity was 3 and is now 17
– Remote UNIX connection
– Executing [1777*******@from-pstn:1] Set(“SIP/1777*******-09d84028”, “__FROM_DID=1777*******”) in new stack
– Executing [1777*******@from-pstn:2] Gosub(“SIP/1777*******-09d84028”, “app-blacklist-check|s|1”) in new stack
– Executing [s@app-blacklist-check:1] LookupBlacklist(“SIP/1777*******-09d84028”, “”) in new stack
– Executing [s@app-blacklist-check:2] GotoIf(“SIP/1777*******-09d84028”, “1?blacklisted”) in new stack
– Goto (app-blacklist-check,s,4)
– Executing [s@app-blacklist-check:4] Answer(“SIP/1777*******-09d84028”, “”) in new stack
– Executing [s@app-blacklist-check:5] Wait(“SIP/1777*******-09d84028”, “1”) in new stack
– Executing [s@app-blacklist-check:6] Zapateller(“SIP/1777*******-09d84028”, “”) in new stack <=================== Stops here

Doesn’t do any of the below:


– Executing [s@app-blacklist-check:7] Playback(“SIP/1777*******-09d84028”, “ss-noservice”) in new stack
– Playing ‘ss-noservice’ (language ‘en’)
– Executing [s@app-blacklist-check:8] Hangup(“SIP/1777*******-09d84028”, “”) in new stack
== Spawn extension (app-blacklist-check, s, 8) exited non-zero on 'SIP/1777*******-09d84028’
KG*CLI>