Bad intermittent echo


#1

We moved our TDM800P card to a newer machine. We have several SIP users and all are now experiencing intermittent echo and sometimes it’s very annoying. The local sip user hears echo but no echo heard by user on other end (pstn). The odd thing is that it’s not always there, even in the same phone call sometimes. I’ve looked online and googled trying to find a fix. I’m hoping someone will have some ideas here.

Details:
[ul]
[li]TDM800P analog card[/li]
[li]SLES 11 SP1 linux[/li]
[li]2.6.32.43-0.4-default x86_64 GNU/Linux kernel[/li]
[li]Asterisk/1.6.2.20[/li]
[li]Asterisk GUI-version : SVN–rexported[/li]
[li]SIP & IAX softphone clients on local side[/li]
[li] * connected to PSTN trunk[/li]
[li]started with mg2 EC and then moved to oslec EC; [/li]
[li]tried different values but currently: echocancel=1024, echocancelwhenbridged=no, echotraining not set[/li]
[li]ran fxotune[/li]
[li]followed online instructions for adjusting rx/tx gains and tried different values; currently rx set to 3 and tx set to -10[/li]
[li]local sip/iax users are using various softphone clients (voix, voiper, blink) on various OSs (win, mac, linux)[/li]
[li]local sip/iax users are using various model headsets[/li]
[li]irq looks good[/li]
[li]result with dahdi_test > 99.99%[/li][/ul]

I’d appreciate any suggestions and help.


#2

Howdy,

Do you have the DSP echo cancellation module VPMOCT032 for the TDM800?


#3

Howdy Malcolm,

No, we don’t have hw echo cancellation.


#4

Howdy,

I’d give it a go, you’ll probably like the results.

If you’re not happy, you can take advantage of this:

digium.com/en/company/view-p … -Guarantee

For Digium’s TDM800, the hw echo module is the VPMOCT032.

Cheers.


#5

Thank you for the suggestion of getting hw echo cancellation. However, since it used to work before the change in machine and * upgrade from v1.4 to v1.62, I was hoping to get it working again. I’m thinking there is a configuration differential somewhere.