Avaya and Asterisk Integration thru H.323

Does H.245 need to be turned on at the Avaya system so that Asterisk can communicate with Avaya using H.323?

I can make the call from Avaya to Asterisk without any problem.

But I can’t make a call from Asterisk to Avaya. When I use the ‘list trac station xxxxx’ command, I got the following message at the Avaya system:

11:00:53 Calling party trunk-group 84 member 1 cid 0x25a
11:00:53 Calling Number & Name XXXX John Doe
11:00:53 active trunk-group 84 member 1 cid 0x25a
11:00:53 dial YYYY
11:00:53 term service-link cid 0x25a
11:00:53 dial YYYY
11:00:53 term service-link cid 0x25a
11:00:53 idle trunk-group 84 cid 0x25a

Any help will be appreciated.

I have been using Avaya h.323 with Asterisk for about a year now in a production environment. It was just a little tricky to fully tweak. But not impossible. Once you can get audio one way from Avaya, my experience is that your Signaling group and Trunk Group are set up OK. Not to say that they couldn’t use some tweaking, but for a call they should be fine.

One thing to look for (I kicked myself after this one) is to ensure your Codecs are in order. I had the exact problem of being able to call from Avaya to Asterisk but not the other way. Just dead air. I am using nothing but g.711 uLaw. I looked at the station configuration on the Asterisk and found that I had everything allowed. I disallowed all and allowed uLaw and viola… Worked like a charm. Just be sure to look at your Avaya Network Region and see what Codec Set it is looking at. Then make sure that Codec Set has g.711 uLaw as the first Codec.

See what Asterisk is saying. Look at the console. (Asterisk -r and then core set debug 9) Also make sure console=notice,warning,error,verbose,debug in the logger.conf file under the logfiles context. When you are ready for this to go to the masses, make sure you take the “debug” out of this statement or your server could be too busy worrying about logs than servicing calls.

I didn’t really see anything in my logs telling me to check my codecs. It’s just something I checked and got lucky but your results may be different.

I do have h.245 tunneling turned on but I think I also had it turned off at one point with no difference that I could tell. It’s turned on right now.

Give these a shot and let me know what you find out. If you still have issues I will see what my configuration looks like and will try to upload it in some readable way.

Good Luck!

Hi pspenn,

Thank you for your respond. I tried your method but it still does not work. Here are my configuration files for Asterisk PBX.

In the extensions.conf file, I have to use ‘exten => _8383,1,Dial(OOH323/${EXTEN}@’ instead of 'exten => _8383,1,Dial(OOH323/${EXTEN}@definity). Why?


callerid="John Doe"




include=> intern

exten => 8390,1,Dial(SIP/8390,20)
exten => 8390,n,voicemail(8390@other,u)
exten => 8390,n,PlayBack(vm-goodbye)
exten => 8390,n,hangup

exten => _8383,1,Dial(OOH323/${EXTEN}@

bindaddr =
progress_setup = 8
progress_alert = 8
gatekeeper = DISABLE


Good Morning,
In the extensions.conf file I notice that the first line, where you are typing the IP address of the definity, doesn’t have the port after the IP address. So mine would look like ‘’ Other than that, it looks fine. ‘definity’ has the port within the Context. At least, that’s how mine looks… The ooh323.conf file probably addresses the port fine but I went ahead and used the port for the time that I used the IP address.

Here’s what my Signal and Trunk Group look like. I hope this helps you.

Group Number: 16 Group Type: h.323
Remote Office? n Max number of NCA TSC: 0
SBS? n Max number of CA TSC: 0
IP Video? n Trunk Group for NCA TSC:
Trunk Group for Channel Selection: 16
Supplementary Service Protocol: a Network Call Transfer? n
T303 Timer(sec): 10

Near-end Node Name: CLAN_2D18 Far-end Node Name: Asterisk_prod1
Near-end Listen Port: 1720 Far-end Listen Port: 1720
Far-end Network Region: 249
LRQ Required? n Calls Share IP Signaling Connection? n
RRQ Required? n
Media Encryption? n Bypass If IP Threshold Exceeded? n
H.235 Annex H Required? n
DTMF over IP: out-of-band Direct IP-IP Audio Connections? n
IP Audio Hairpinning? n
Interworking Message: PROGress
DCP/Analog Bearer Capability: 3.1kHz

Group Number: 16 Group Type: isdn CDR Reports: y
Group Name: Asterisk_prod1 COR: 1 TN: 1 TAC: 816
Direction: two-way Outgoing Display? n Carrier Medium: H.323
Dial Access? n Busy Threshold: 255 Night Service:
Queue Length: 0
Service Type: tie Auth Code? n
Member Assignment Method: auto
Signaling Group: 16
Number of Members: 200

  Group Type: isdn

Codeset to Send Display: 6 Codeset to Send National IEs: 6
Charge Advice: none
Supplementary Service Protocol: b Digit Handling (in/out): enbloc/enbloc

                                                 QSIG Value-Added? n
                                               Digital Loss Group: 18

Incoming Calling Number - Delete: Insert: Format: pub-unk

Disconnect Supervision - In? y Out? y
Answer Supervision Timeout: 0

ACA Assignment? n Measured: external
Internal Alert? n Maintenance Tests? y
Data Restriction? n NCA-TSC Trunk Member:
Send Name: y Send Calling Number: y
Used for DCS? n Hop Dgt? n Send EMU Visitor CPN? y
Suppress # Outpulsing? n Format: public
UUI IE Treatment: service-provider

                                             Replace Restricted Numbers? n
                                            Replace Unavailable Numbers? n
                                                  Send Connected Number: y
                                              Hold/Unhold Notifications? y
         Send UUI IE? y                    Modify Tandem Calling Number? n
           Send UCID? n

Send Codeset 6/7 LAI IE? y

                   QSIG TRUNK GROUP OPTIONS

       Diversion by Reroute? y
           Path Replacement? y

Path Replacement with Retention? n
Path Replacement Method: better-route
SBS? n
Display Forwarding Party Name? y
Character Set for QSIG Name: eurofont

Does anything in here look different from yours?

Hi Perry,

Thank you for all of your help. This confirm that H.245 is not required if I need to use H.323 trunk.

I modified the trunk group and signaling group parameters like yours and it works.

I will reverse back to my old configuration and slowly modify each one of them again and see which parameters I actually need to modify. I will keep your posted.

Again, thank you for your help.


I’m glad to help.