Audio quality in Elastix voice message

Hi all,
i start this topic in a general way, because i not know if i can explain good.
I have an Elastix 2.3.0 installed (Kernel 2.6.18, Asterisk
The call quality is good, i can ear the voice of the caller and the caller can ear my voice in a really good way.
Recently i implement an IVR.
For give at IVR a professional quality, i make all voice massage of IVR (like: “Welcome to xxx, press 1 for yyy, 2 for zzz”) trought a professional voice studio.
The voice file arrive to me with a really good quality.
I try make all the necessary conversion for use the voice file in elastix, but no one give me a good audio quality, of this message, in IVR call.
In addition, the IVR is combined with GOOGLE TTS service, and this service too is not good in voice quality (yes, of course, is like a robot voice, but is not cleared voice).
Anyone know third party product, codec or configurations that can help me in tuning this part of audio quality?
Thanks all,

If the sound is choppy, have you enabled internal timing, and what timing source are you using.

Please note that your Asterisk is an obsolete, unsupported one. It is far from the latest, even on the 1.6.2 branch.

Hi david.
Thanks for your reply.
I not know if i understand good, but i can say that time is synked and ntpd service is up and running.
I’ve time synked with 3 external server:

and the DNS is able to resolve it.
I not can figure that time have a part in the sound quality. Thanks for this.

Is the Asterisk internal_timing option set to yes? Do you have dahdi loaded, and recognized by Asterisk? Do you have any other timing options set in asterisk.conf. Note. As you are not using the end of life version of 1.6.2, it is probable that other timing sources are broken.

Thanks David
Yes, the internal timing is “Enabled”.

PBX Core settings

Maximum calls: Not set
Maximum open file handles: Not set
Verbosity: 34
Debug level: 0
Maximum load average: 0.000000
Minimum free memory: 0 MB
Startup time: 03:02:23
Last reload time: 17:02:08
System: Linux/2.6.18-164.6.1.el5.100hz built by root on i686 2010-10-03 20:56:35 UTC
System name:
Entity ID: 00:0c:29:a2:0f:71
Default language: en
Language prefix: Enabled
User name and group: /
Executable includes: Enabled
Transcode via SLIN: Enabled
[color=#0040FF] Internal timing: Enabled[/color]
Transmit silence during rec: Enabled
Generic PLC: Enabled

  • Subsystems

    Manager (AMI): Enabled
    Web Manager (AMI/HTTP): Disabled
    Send Manager FullyBooted: Disabled
    Call data records: Enabled
    Realtime Architecture (ARA): Disabled

  • Directories

    Configuration file:
    Configuration directory: /etc/asterisk
    Module directory: /usr/lib/asterisk/modules
    Spool directory: /var/spool/asterisk
    Log directory: /var/log/asterisk

This version of “Elastix” is not really old (not the last, but of this year). Maybe the distribution not use the last version of asterisk.