Attempting native bridge of MGCP... and SIP


#1

Hey,

I am setting up my asterisk server, amongst other things I wanted to be able to use ENUM directory. I tried calling the number on their website and this is what I get :

Called 1000@mutual.bcwireless.net
– SIP/mutual.bcwireless.net-4f12 answered MGCP/aaln/1@[mac address]-1
– MGCP mgcp_answer(MGCP/aaln/1@[mac address]-1) on aaln/1@[mac address]-1
– Attempting native bridge of MGCP/aaln/1@[mac address]-1 and SIP/mutual.bcwireless.net-4f12
– Endpoint ‘aaln/1@[mac address]-1’ observed ‘hu’

I get no audio in this situation. If I try the same situation except from a
SIP softphone instead of a MGCP ata, it works perfectly.

Tried another number, I heard half a second of audio than the “Native Bridge message appeared”. Can I disable “Native Bridging” for MGCP to Sip calls and vice versa?

asterisk 1.0.7 on debian.

Thanks,

David


#2

I am also getting the following warnings.

Feb 21 19:24:33 NOTICE[6567]: channel.c:1757 ast_set_read_format: Unable to find a path from g729 to ulaw
Feb 21 19:24:33 NOTICE[6567]: channel.c:1724 ast_set_write_format: Unable to find a path from gsm to g729
Feb 21 19:24:33 WARNING[6567]: chan_sip.c:1829 sip_write: Asked to transmit frame type 2, while native formats is 256 (read/write = 4/2 )