Attempting native bridge of SIP/(client) and SIP/sip.broad)


#1

hi ,

i have installed a asterisk in red hat linux box and and configured the dial plan. i am able to connect to linux box (asterisk server) from softphone.when ever i try to make a outbound call . i am getting the voice messeage “you cannot make the make the call , please contact system administrator”

i asterisk CLI prompt it shows that

Attempting native bridge of SIP/(client)-2707 and sip/sip.broadvoice.com.

after that

==spawn extension ((name),number#,1) exited non-zero on sip/client -2707

i am very sure the asterisk is registered with broadvoice.

I shall be thankfull , if you help to resove the issue.
[/b]


#2

Hi,

You should post the relevant dial plan, and any relevant details from sip.conf.

Cheers,
john


#3

Hi,

My dial plan is in extension.conf is

[general]
static=yes
writepdotect=no
autofalthroguh=yes
clearglobalvars=no
[global]
Console=console/dsp

[test]
exten => _NXXNxxxxxx,1,dial(SIP/$ (EXTEN)@sip.broadvoice.com,30)
exten => _NXXNxxxxxx,2,congenstion()
exten => _NXXNxxxxxx,102,busy

exten => 1004,1,Dial(SIP/1,60,rT)
exten => 1005 ,1,Dial(SIP/2,60,rT)

and sip.conf is

[general]
context=default
bindport=5060
bindaddress=0.0.0.0
srvlookup=yes
pedantic=no

register=> number#@sip.broadvoice.com:password:number#@sip.broadvoice.com/1004

[sip.broadvocie.com]
type=peer
user=phone
host=sip.braodvoice.com
fromdomain=sip.broadvoice.com
fromuser=number#
secret=password
username=number#
insecure=very
context=test
authname=number#
dmf=inband
canreinvite=no

[1]
type=friend
secret =blak
host=dynamic
qualify=yes
conext=test
dtmfmode=rfc2833
canreinvite=no
allow=ulaw
[2]
type=friend
secret =blak
host=dynamic
qualify=yes
conext=test
dtmfmode=rfc2833
canreinvite=no
allow=ulaw

Please help me out thi situtation.

Rizwan


#4

Any help reg. issue will be appreciated.

Rizwan


#5

In section [1] and [2] try change conext=test to context=test.

Regards.

Marco Bruni


#6

You have tons of spelling mistakes. I don’t know if you cut and pasted this, or perhaps retyped it. If you cut and pasted it from the real config files, there’s no chance it will work until you clean up all the spelling errors.


#7

Hi,

It was my spelling mistake and i can tell you that i have retyped it so that only spelling mistake occurs here :frowning: .Also i assure that i have once rechecked it … there is no mistakes in spelling at all in the config files. :exclamation:

But still, whenever i try to make calls out it says “Attempt to native bridging occurs”

i shall be thankfull, if you tell the way where i have to check and change, so that it will be very helpfull to me.

Thanks in advance


#8

[quote]Any help friends [/quote]

Thanks in advance


#9

OK, I’m still somewhat of a newbie myself, but let’s try to get some more info.

Is your softphone either [1] or [2] in sip.conf?

You can confirm you’re registered with broadvoice with “sip show registry” at the CLI. Have you checked this?

What number are you dialing (you don’t have to post the number, but show something representative so we can see what pattern it matches in the dial plan).

Is there anything else in the console output (besides what you posted in your original post)? Are you running with a high level of verbosity (e.g., asterisk -vvvvvvvvr)?

For example, when I make a call to telasip from my ATA-attached analog phone, I get output something like this (I substituted xxxxxxx for the actual number):

-- Executing Dial("SIP/john-desk-8db7", "SIP/925xxxxxxx@telasip-gw|60") in new stack -- Called 925xxxxxxx@telasip-gw -- SIP/telasip-gw-a323 is ringing -- SIP/telasip-gw-a323 answered SIP/john-desk-8db7 -- Attempting native bridge of SIP/john-desk-8db7 and SIP/telasip-gw-a323 == Spawn extension (custom-callboth, 925xxxxxxx, 5) exited non-zero on 'SIP/john-desk-8db7' -- Remote UNIX connection

The “SIP/telasip… is ringing” and “SIP/telasip… answered” messages show call progress. When the call is answered, it is bridged, as shown in the Attempting native bridge.

Comparing this to yours, it seems like you’re getting connected (you get the attempting native bridge message). Is it after this message that you get the recording?

Is it possible the target number on the PSTN has some problem? Can you call it from a regular land line? Can you call a different number through asterisk and get the same recording?


#10

Hi,

1.I use only softphones for testing. even i mentioned [1] and [2] this too softphones.

2.i checked the sip show registry and saw it is registered with broadvoice.

3.i dial 732XXXXXXX

4.Yes i run high level of verbosity verbosity set to 27… and i use asterisk -vvvvvvvvvvvvvc

5.Yes i get the recording after this native bridging message.

6.I tried several pstn number from sip softphone.i got the same error in cli prompt.


#11

Can you get through to this number from a regular land line?

Sorry, I’m not sure what else to suggest. It looks to me like you’re connecting to Broadvoice, and perhaps you have some authorization issue with them. I’m thinking that the recording is coming from them. If that’s the case, I think you need to talk to their tech support.

One other idea: Have you tried connecting directly to Broadvoice with your sip softphone (taking Asterisk out of the equation)? This might help debug things when you talk to Broadvoice anyway.


#12

Hi,

1.Noi do have icoming issue from calling this number form regular land line number.

2.i tried by connecting directly with broadvoice using sip softphone, it works great!


#13

Any help on this my friends.


#14

is the server on a real IP or on NAT?


#15

I asked:

You answered:

Sorry, but I can’t parse that answer. Do you have the same problem when calling that number from a land line that you have when calling from asterisk?

When you said

Again, I’m not sure I understand. Can you use a sip softphone to call the same phone number that you’re dialing through Asterisk and successfully complete the call?


#16

Hi,

Asterisk server in real public ip.

when i call from regular pstn line to this number … the call reaches the asterisk server after that it says that extenions i am trying to is busy… and giving broadvoice voice mail tone.

When i call from asterisk… it says attempting to native bridging.

it is different issue…

i configured the same sip number from broadvoice to the sip softphone directly to reach the broadvoice by passing asterisk… it work great…

please let me know any more info needed.


#17

Rizwan,

I’m sorry, but I’m confused.

[quote]when i call from regular pstn line to this number … the call reaches the asterisk server after that it says that extenions i am trying to is busy… and giving broadvoice voice mail tone.
[/quote]

What does this mean?

Are you calling IN to your own asterisk server?

Here’s what I’m suggesting you test:

  • find a regular PSTN number (e.g., a friend’s home phone number, or a Sears Tire Department for that matter) that you know you can reach through the normal pstn
  • dial that number via asterisk/broadvoice and report back what happens
  • if you can’t connect via asterisk, try going directly from softphone to broadvoice and call that same number and see if it works.

I’m just trying to narrow down whether it’s a problem with a) ALL incoming calls at the number you’re dialing, b) outgoing calls from asterisk, or c) your connection to broadvoice.

Good luck.
john


#18

Hi john,

Now i changed the config in in extensions.conf

[test]
exten => _NXXNxxxxxx,1,dial(SIP/$ {EXTEN}@sip.broadvoice.com,30)
exten => _NXXNxxxxxx,2,congenstion()
exten => _NXXNxxxxxx,102,busy

exten => 1004,1,Dial(SIP/1,60,rT)
exten => 1005 ,1,Dial(SIP/2,60,rT)

The bolded portion earlier i gave as (EXTEN)… so only outgoing call was the problem… out going is ok from asterisk.

now i face the incoming call issues.

whenever i dial 732XXXXXXX number from my cell/other pstn line … it says the party you are trying to reach is busy… please leave voice mail. i am sure it is briadvoice voice mail system.

also now i am not seeing any logs which indicated the call landing on the asterisk fromoutside.

i am assuming now the incoming is not all landing on the asterisk…

please help


#19

thanks friends


#20

hello rizwan,

its good i was observing all ur conversation.

cheers… :smiley: :smiley: