ATA wont stay registered - stale nonce

I have a bunch of ATAs out at customer sites (all behind NAT) that register just fine to my trusty SER proxy, but when I moved them recently to my shiny new asterisk box, they registered intially for an hour or so then unregistered and wouldnt re-register, the error appears to be related to a stale nonce (see debug output below), I have a vague idea what that is but absolutley no idea what may cause it. Anyone?

<-- SIP read from :5060:
REGISTER sip:sip2.domain.com SIP/2.0
Via: SIP/2.0/UDP 10.200.1.5:5060
From: sip:2077@sip2.domain.com;user=phone;tag=3742862933
To: sip:2077@sip2.domain.com;user=phone
Call-ID: 1843920716@10.200.1.5
CSeq: 36 REGISTER
Contact: sip:2077@10.200.1.5:5060;user=phone;transport=udp;expires=120
User-Agent: Cisco ATA 186 v3.1.0 atasip (040211A)
Authorization: Digest username=“2077”,realm=“sip2.domain.com”,nonce=“1ed3611a”,uri=“sip:sip2.domain.com”,response="2af4216999b91b9e5252b93b396fbc27"
Content-Length: 0

May 24 00:22:24 VERBOSE[17125] logger.c: — (10 headers 0 lines)May 24 00:22:24 VERBOSE[17125] logger.c: — (10 headers 0 lines)—
May 24 00:22:24 VERBOSE[17125] logger.c: Using latest REGISTER request as basis request
May 24 00:22:24 VERBOSE[17125] logger.c: Sending to 10.200.1.5 : 5060 (NAT)
May 24 00:22:24 VERBOSE[17125] logger.c: Transmitting (NAT) to :5060:
SIP/2.0 100 Trying
Via: SIP/2.0/UDP 10.200.1.5:5060;received=
From: sip:2077@sip2.domain.com;user=phone;tag=3742862933
To: sip:2077@sip2.domain.com;user=phone
Call-ID: 1843920716@10.200.1.5
CSeq: 36 REGISTER
User-Agent: Asterisk PBX
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
Contact: <sip:2077@>
Content-Length: 0


May 24 00:22:24 NOTICE[17125] chan_sip.c: stale nonce received from 'sip:2077@sip2.domain.com;user=phone
May 24 00:22:24 VERBOSE[17125] logger.c: Transmitting (NAT) to :5060:
SIP/2.0 401 Unauthorized
Via: SIP/2.0/UDP 10.200.1.5:5060;received=
From: sip:2077@sip2.domain.com;user=phone;tag=3742862933
To: sip:2077@sip2.domain.com;user=phone;tag=as2e86d8a5
Call-ID: 1843920716@10.200.1.5
CSeq: 36 REGISTER
User-Agent: Asterisk PBX
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
Contact: <sip:2077@>
WWW-Authenticate: Digest realm=“sip2.domain.com”, nonce=“6de00409”, stale=true
Content-Length: 0

Hey,

Did you find a solution to this… I seem to be having the same issue with a bunch of sipura ata’s.

Thanks.