AsteriskGUI 2.0 on Asterisk 1.6.1-r175593

I have tried every combination of builds using AstriskNOW 1.5, several different builds of Asterisk 1.4 and 1.6 and for the life of me I can get incoming called when I use GUI 2.0. FreePBX worked in AsteriskNOW 1.5 and I can configure sip.conf and extensions.conf by hand and get incoming and outgoing working but once it is impossible to get incoming calls if I configure it with GUI 2.0.

I get this error in the log when caling in from a PSTN line.:
chan_sip.c: Call from ‘XN12tw63pzcK7Y’ to extension ‘XXXXXXXXXX’ rejected because extension not found.

I am running the latest svn builds of dahdi-linux, dahdi-tools, asterisk, asterisk-addons, asterisk-gui. I am running a bare bones CentOS 5.2 that is all yummed up.

I don’t have any hair left to pull. Any hints other then ditch the GUI? It is hard to believe the GUI isn’t capable of the most basic setup.


Is there a reason you are trying 1.6.x? I have had lots of success with gui 2.0 and asterisk-1.4.x

Not really. The past few days are my first experience with Asterisk. I figured I would go with the newest of everything. I will give 1.4 a shot today. Thanks for the response.

Figured it out. The pattern I was using for the incoming call rules was messed up. I feel stupid now. :smile:

Thanks for the help.