Asterisk18 on PLCNext

Hello,

I am a Student and I am trying to run Asterisk18 on a PLCNext F2152 Controller. When i try tro run Asterisk I always got the error massage:
error while loading shared libraries: libcap.so.2: cannot open shared object file: No such file or directory
But if I run ldd asterisk
I got this:
** libssl.so.1.0.0 => /opt/lib/libssl.so.1.0.0 (0xb6eb5000)
libcrypto.so.1.0.0 => /opt/lib/libcrypto.so.1.0.0 (0xb6d15000)
libc.so.6 => /opt/lib/libc.so.6 (0xb6bda000)
libxml2.so.2 => /opt/lib/libxml2.so.2 (0xb6aaa000)
libz.so.1 => /opt/lib/libz.so.1 (0xb6a80000)
libm.so.6 => /opt/lib/libm.so.6 (0xb69fe000)
libdl.so.2 => /opt/lib/libdl.so.2 (0xb69eb000)
libcap.so.2 => /lib/libcap.so.2 (0xb69d6000)
libpthread.so.0 => /opt/lib/libpthread.so.0 (0xb69ad000)
libresolv.so.2 => /opt/lib/libresolv.so.2 (0xb698a000)
**
I have not much experience with Linux or Asterisk. So I hope someone can point me into the right direction to solve this problem.
Thank you guys.

File permissions?

Then again, why do you need libcap.so?

I find it odd that is is in a different directory from the other libraries.

I think I sloved the Problem with this guid:

https://wiki.qnap.com/wiki/Asterisk

Isn’t the qnap optware stuff like ipkg obsolete since 2019? The are less painful ways to get Asterisk running.

I didnt know any other way. I have not that much experience. How would you do it?

Hello, show please output of command locate libcap.so.2

locate command not found

I can run Asteriks, but not all modules are loading.

Exactly which version are you using?

Did you enable those modules when building Asterisk, or how did you obtain the Asterisk binary? The sound card and CLI dialling features are rarely used.

If you built it did make menuconfig show the also module as enabled. If it couldn’t be enabled, what were listed as the failed dependencies?

Ok, so i dont need them?
Thats what I did:
ipkg install asterisk18
ipkg install asterisk-gui
I have a screenshot with my version.


.

Asterisk GUI is very definitely no longer supported.

You are using Asterisk 1.8, not Asterisk 18. Asterisk 1.8 went security fixes only almost 7 years ago, and has been completely unsupported for almost 6 years. Asterisk 1.8.25.0 is from December 2013, and was not the last 1.8 sub-version.

There is no reasonable expectation of getting support for that version from the Asterisk community. Also, you seem to be using third party packages, so you should obtain support from that third party, especially to the extent that the issues relates to missing modules or other options.

Can you run the following command to check for the location of the libasound library
find / -name “libasound.*”
and paste the output in a reply here?

When I run this command nothing is found.

Try to do this ipkg install libasound2 or ipkg install alsa-lib alsa-utils then restart your asterisk and check if module chan_alsa.so is loaded.

This one worked : ipkg install alsa-lib alsa-utils
Thank you. But i think I have not understand some fundamental things about Asterisk.

The recent guidance hasn’t really been about Asterisk, but rather about the the OS on which it is running. Although I think it is likely that adamantin has had some experience with Asterisk on your platform, or some similar embedded Linux platform, the procedures for finding and installing missing libraries don’t really require any knowledge of Asterisk, but they do tend to require one to know which OS packages contain which components.

Incidentally, Wikipedia thinks that ipkg is end of life, as well.