Asterisk trunk: not getting BYE/CANCEL when caller terminates/trunk terminating too early

I’m using Asterisk 18.3.0 on FreeBSD 13.-STABLE. I utilize two SIP accounts from different SIP provider in Germany, one is sipgate, the other Telefonica/O2 (an Iberain company). Except the specific settings for URI et cetera, the endpoints for incoming and outgoing created are almost identical.
I’m not a day-to-day SIP/Asterisk expert, so have mercy!

Configuration scheme is PJSIP.

I’m behind NAT.

Since a couple of days for now, after a minor change to the config files according to some necessary updates, one SIP trunk, associated with Telefonica/O2, is acting different and weird.
When calls come in on that line, the RINGTIME is set to 20 sec (on all inbound calls, set by variable), the phones start ringing. After approximately seven seconds the caller party gets the message that the called person is unavailable ("The number you have dialed is temporaraily unavailable …) - but the phone are still ringing until the time of 20 sec is up and Asterisk starts trying to record a voicemail.
When calling myself from another line external to my Asterisk, say via my wireless, Asterisk starts also ringing the phones, but when I then cancel/hangup the call, asterisk continues to ring the phones until it starts trying to record a voicemail (see the log in CLI or logfile so far).

Performing the same task with the alternate sipgate provider, not problem so far occurs, when pressing the cancel button on my wireless, asterisk terminates all ringing on the phones and the inbound call stops immediately. A inbound call lasts exactly 20 sec before Asterisk starts the voicemail recording.

The weird part is that it worked until a couple of days ago.

Since then, I try to check the setups side-by-side via eyeball checking where differences could occur especially in the ingress endpoind. No success so far.

Also I tried to check debug logs for both descibed call schemes above to figure out what’s essentially different, but I do not get anything out of it since I do not know where I have to look for exactly, I’m helpless here

Asterisk doesn’t send calls to voicemail unless you configure it to. In fact it doesn’t do anything with calls until you do that. You need to provide us with the dialplan you are actually using, to understand the sequence of things, in particular when Asterisk will answer the call.

The unavailable after 7 seconds suggests that no responses are reaching the provider, from Asterisk.

Having the “psjsip set logger on” output, from the full log, would greatly help understand what is going on, but NAT would be the first candidate as the source of the problem.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.