Asterisk SIP register dialog as client

I’ve got Internetplusbellen in the Netherlands. (VoIP from telephone company KPN)
I have a problem connecting Asterisk with the SIP Proxy (Experiabox)

I use Asterisk 1.4.5, but had the same problem with 1.2.18

When registering to the Experiabox with the softphones X-lite or IDEFISK with account 102, password 102 and callerid = 102 it works fine, but Asterisk seems to fail as an UA. When Asterisk sends the challenge response to the Experiabox the Experiabox (SIP Proxy) still sends a 401 ?

When debugging SIP and Asterisk console and Wireshark, I can see the SIP REGISTER dialogs are different.

X-lite adds 2 extra variables in the first message of the REGISTER dialog in the Contact: header being: rinstance=;expires=0
Asterisk is missing these variables.
Contact Binding: rinstance and expires variables missings aswell.

To: header X-lite is To: "102"sip:102@
To: header Asterisk is To: sip:

Within X-lite the Allow option is send:
Asterisk only sends this when the OPTIONS dialog is send.

Within X-lite the header SIP Display info: “102” is given
Asterisk is missing this header although caller-id is set to 102.

Any help ? Is there a way to change the behaviour of Asterisk as a UA ?

By the way X-lite and IDEFISK clients successfully connect to Asterisk as a SIP REGISTRAR. So I know how to setup Asterisk as a server/registrar.

Arghhh frustrating as it seems so simple ! The Softphones simply work without any tweaking… Just use username 102, password/secret 102 and domain (Experiabox)

Thanks in advance,